aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngquant
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-09-30 13:57:59 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-09-30 13:57:59 +0000
commite05d705eae61fafdc702e8f4255435145629ab4a (patch)
treeabea8e381839931fde94553362138ab122c9a225 /graphics/pngquant
parent5cdb5ad11941279bb3ac5995baec28cd335e931f (diff)
downloadports-e05d705eae61fafdc702e8f4255435145629ab4a.tar.gz
ports-e05d705eae61fafdc702e8f4255435145629ab4a.zip
- Update to 2.0.0 [1]
- Convert to USES=gmake [1] - Convert to options helpers - Convert to new LIB_DEPENDS syntax - Support STAGEDIR - Take maintainership PR: ports/181894 (based on) [1] Submitted by: KATO Tsuguru <tkato432@yahoo.com> [1]
Notes
Notes: svn path=/head/; revision=328787
Diffstat (limited to 'graphics/pngquant')
-rw-r--r--graphics/pngquant/Makefile63
-rw-r--r--graphics/pngquant/distinfo4
2 files changed, 28 insertions, 39 deletions
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
index a66dac96be98..43f9365a24a2 100644
--- a/graphics/pngquant/Makefile
+++ b/graphics/pngquant/Makefile
@@ -2,67 +2,56 @@
# $FreeBSD$
PORTNAME= pngquant
-PORTVERSION= 1.8.3
+PORTVERSION= 2.0.0
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= http://pngquant.org/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ak@FreeBSD.org
COMMENT= Converts 32-bit RGBA PNGs into 8-bit RGBA-palette PNGs
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP DEBUG DOCS
-OPTIONS_DEFINE_i386= SSE
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
-USE_CSTD= c99
-USE_GMAKE= yes
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+USES= gmake
+MAKE_ARGS+= CC="${CC}"
CPPFLAGS+= $$(libpng-config --I_opts)
-LDFLAGS+= $$(libpng-config --ldflags) -lz -lm
+LDFLAGS+= $$(libpng-config --ldflags)
-MAN1= pngquant.1
PORTDOCS= CHANGELOG README.md
-PLIST_FILES= bin/pngquant
+PLIST_FILES= bin/pngquant \
+ man/man1/pngquant.1.gz
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= OPTIMIZED_FLAGS OPENMP DEBUG DOCS
+OPTIONS_DEFINE_i386= SSE
-.if empty(PORT_OPTIONS:MDEBUG)
-CFLAGS+= -DNDEBUG
-.endif
+OPTIMIZED_FLAGS_CFLAGS= -O3 -fearly-inlining -fstrict-aliasing \
+ -ffast-math -funroll-loops -fomit-frame-pointer \
+ -fexpensive-optimizations -ffinite-math-only \
+ -funsafe-loop-optimizations -ftree-vectorize
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -fearly-inlining -fstrict-aliasing -ffast-math \
- -funroll-loops -fomit-frame-pointer -fexpensive-optimizations \
- -ffinite-math-only -funsafe-loop-optimizations -ftree-vectorize
-.endif
+# SSE2 support is always enabled on amd64
+SSE_CFLAGS= -DUSE_SSE=1 -msse2
-.if ${PORT_OPTIONS:MOPENMP}
-CFLAGS+= ${PTHREAD_CFLAGS} -fopenmp
-LDFLAGS+= ${PTHREAD_LIBS} -lgomp
-.endif
+OPENMP_CFLAGS= -fopenmp
+OPENMP_LDFLAGS= -lgomp -pthread
-# SSE2 support is always enabled on amd64
-.if ${PORT_OPTIONS:MSSE}
-CFLAGS+= -DUSE_SSE=1 -msse2
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MDEBUG)
+CFLAGS+= -DNDEBUG
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pngquant ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pngquant.1 ${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/pngquant ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pngquant.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/pngquant/distinfo b/graphics/pngquant/distinfo
index 84c0d8ac83d5..9e5f53fc9a7a 100644
--- a/graphics/pngquant/distinfo
+++ b/graphics/pngquant/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pngquant-1.8.3-src.tar.bz2) = e3d18b12ddf4ee159a696408b147d667674e52121f11660fc15ce3967dd053b9
-SIZE (pngquant-1.8.3-src.tar.bz2) = 32287
+SHA256 (pngquant-2.0.0-src.tar.bz2) = 449a4e1a7e6bf2e19b4dd3c91e8239c51cc651eeb5781c38cbaf7c852384039f
+SIZE (pngquant-2.0.0-src.tar.bz2) = 44613