aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngwriter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-29 13:55:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-29 13:55:02 +0000
commit9be85b40c3e08c545a13d80b224c87684ff6ec93 (patch)
tree381d22407869e6b165660e336bd4e026560f836e /graphics/pngwriter
parent244c703e25cf40b631e8f4f52ece8f2c83a1a89f (diff)
downloadports-9be85b40c3e08c545a13d80b224c87684ff6ec93.tar.gz
ports-9be85b40c3e08c545a13d80b224c87684ff6ec93.zip
- fix build for png-1.4.1
Notes
Notes: svn path=/head/; revision=251726
Diffstat (limited to 'graphics/pngwriter')
-rw-r--r--graphics/pngwriter/Makefile2
-rw-r--r--graphics/pngwriter/files/patch-pngwriter.cc22
2 files changed, 23 insertions, 1 deletions
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index 4de4288b75e7..4ca373f71034 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_GNOME= pkgconfig
-CXXFLAGS+= `pkg-config --cflags freetype2 libpng12` -I${LOCALBASE}/include
+CXXFLAGS+= `pkg-config --cflags freetype2 libpng14` -I${LOCALBASE}/include
PORTDOCS= *
PORTEXAMPLES= *
diff --git a/graphics/pngwriter/files/patch-pngwriter.cc b/graphics/pngwriter/files/patch-pngwriter.cc
new file mode 100644
index 000000000000..8ea130fba529
--- /dev/null
+++ b/graphics/pngwriter/files/patch-pngwriter.cc
@@ -0,0 +1,22 @@
+--- src/pngwriter.cc.orig 2009-02-10 22:45:16.000000000 +0100
++++ src/pngwriter.cc 2010-03-29 15:55:32.000000000 +0200
+@@ -1204,8 +1204,8 @@
+ FILE *fp;
+ png_structp png_ptr;
+ png_infop info_ptr;
+- unsigned char **image;
+- unsigned long width, height;
++ png_byte **image;
++ png_uint_32 width, height;
+ int bit_depth, color_type, interlace_type;
+ // png_uint_32 i;
+ //
+@@ -1311,7 +1311,7 @@
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth<8)
+ {
+ // png_set_expand(png_ptr);
+- png_set_gray_1_2_4_to_8(png_ptr); // Just an alias of the above.
++ png_set_expand_gray_1_2_4_to_8(png_ptr); // Just an alias of the above.
+ transformation_ = 1;
+ }
+