aboutsummaryrefslogtreecommitdiff
path: root/graphics/podofo
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-11-14 18:00:27 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-11-14 18:00:27 +0000
commit3910e557b8aad71a5c51157a4a80670a021c9bcc (patch)
tree320efdf28d66744317bf41e02f3cec53f7294051 /graphics/podofo
parent6e9971b67370a42fe1894d9eeb9dd30c408640fc (diff)
downloadports-3910e557b8aad71a5c51157a4a80670a021c9bcc.tar.gz
ports-3910e557b8aad71a5c51157a4a80670a021c9bcc.zip
Fix build with gcc5
PR: 213996 (based on) Submitted by: Kenneth Salerno
Notes
Notes: svn path=/head/; revision=426128
Diffstat (limited to 'graphics/podofo')
-rw-r--r--graphics/podofo/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 8837d63262cc..39df2e781e33 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= cmake dos2unix ssl
+USES= cmake compiler dos2unix ssl
CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
-DPODOFO_BUILD_STATIC:BOOL=FALSE \
-DOPENSSL_INCLUDE_DIR:PATH="${OPENSSLINC}" \
@@ -43,4 +43,10 @@ PNG_LIB_DEPENDS= libpng.so:graphics/png
TIFF_CMAKE_ON= -DWANT_TIFF:BOOL=TRUE
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} >= 50
+CXXFLAGS+= -std=gnu++11 -D_GLIBCXX_USE_C99=1
+.endif
+
+.include <bsd.port.post.mk>