aboutsummaryrefslogtreecommitdiff
path: root/graphics/podofo
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-31 01:28:29 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-31 01:28:29 +0000
commit4687c013098104c414130e05cf3da383f6c5ad28 (patch)
tree70fb1f27108e1ef03305edd07ef487b05d809add /graphics/podofo
parent9eaeb01c59ac296e0f2e4531b40636a864b87d24 (diff)
downloadports-4687c013098104c414130e05cf3da383f6c5ad28.tar.gz
ports-4687c013098104c414130e05cf3da383f6c5ad28.zip
graphics/podofo: require C++11 compiler
Fixes build of print/scribus-devel on GCC architectures: /usr/local/bin/ld: pdf_analyzer.cpp:(.text+0x33d8): undefined reference to `PoDoFo::PdfName::GetEscapedName[abi:cxx11]() const' /usr/local/bin/ld: scribus/CMakeFiles/scribus.dir/pdf_analyzer.cpp.o: in function `PDFAnalyzer::inspectCanvas(PoDoFo::PdfCanvas*, QList<PDFColorSpace>&, bool&, QList<PDFFont>&, QList<PDFImage>&) [clone .localalias]':
Notes
Notes: svn path=/head/; revision=521578
Diffstat (limited to 'graphics/podofo')
-rw-r--r--graphics/podofo/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 63c7c0d1365e..e5111b34df76 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -26,7 +26,7 @@ CMAKE_ARGS= -DFONTCONFIG_LIBRARIES=${LOCALBASE}/lib/libfontconfig.so \
-DOPENSSL_LIBRARIES=${OPENSSLDIR}
CMAKE_ON= PODOFO_BUILD_SHARED PODOFO_BUILD_STATIC
USE_LDCONFIG= yes
-USES= cmake compiler dos2unix pkgconfig ssl
+USES= cmake compiler:c++11-lang dos2unix pkgconfig ssl
DOS2UNIX_FILES= cmake/modules/FindFREETYPE.cmake