aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2013-03-21 05:27:16 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2013-03-21 05:27:16 +0000
commit8112386f17f76b88b55b21d5884cef5b05ed3069 (patch)
treec071769bfc107a2663404651db1a2a29a9d85c31 /graphics/poppler/Makefile
parent9646a1edaa683005bfa38103030f1620566f0aba (diff)
downloadports-8112386f17f76b88b55b21d5884cef5b05ed3069.tar.gz
ports-8112386f17f76b88b55b21d5884cef5b05ed3069.zip
Notes
Diffstat (limited to 'graphics/poppler/Makefile')
-rw-r--r--graphics/poppler/Makefile63
1 files changed, 28 insertions, 35 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index 29a113e3b50a..337cd0421d2a 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: poppler
-# Date created: 03 March 2005
-# Whom: marcus@FreeBSD.org
-#
+# Created by: marcus@FreeBSD.org
# $FreeBSD$
-# $MCom: ports/graphics/poppler/Makefile,v 1.74 2011/08/05 14:05:23 kwm Exp $
-#
+# $MCom: ports/graphics/poppler/Makefile,v 1.84 2013/03/12 14:53:49 kwm Exp $
PORTNAME= poppler
-PORTVERSION= 0.18.4
-PORTREVISION?= 2
+PORTVERSION= 0.22.2
+PORTREVISION?= 0
CATEGORIES= graphics print
MASTER_SITES= http://poppler.freedesktop.org/
@@ -17,9 +13,9 @@ COMMENT?= A PDF rendering library
LICENSE= GPLv2
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- lcms.1:${PORTSDIR}/graphics/lcms
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ lcms2:${PORTSDIR}/graphics/lcms2
RUN_DEPENDS= poppler-data>0:${PORTSDIR}/graphics/poppler-data
USE_GMAKE= yes
@@ -35,18 +31,21 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if !defined(SLAVEPORT)
-OPTIONS= CAIRO "Enable cairo output backend" on \
- OPENJPEG "Enable JPEG 2000 support" on
+PORTSCOUT= limitw:1,even
+
+OPTIONS_DEFINE= CAIRO OPENJPEG
+OPTIONS_DEFAULT=CAIRO OPENJPEG
.endif
.include <bsd.port.options.mk>
.if defined(SLAVEPORT)
-LIB_DEPENDS+= poppler.18:${PORTSDIR}/graphics/poppler
+PORTSCOUT= ignore:1
+LIB_DEPENDS+= poppler:${PORTSDIR}/graphics/poppler
.if ${SLAVEPORT}=="glib"
BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
CONFIGURE_ARGS+=--enable-poppler-glib
USE_GNOME+= gnomehier glib20
BUILD_WRKSRC= ${WRKSRC}/glib
@@ -59,23 +58,20 @@ CONFIGURE_ARGS+=--disable-poppler-glib
CONFIGURE_ARGS+=--enable-poppler-qt4
CONFIGURE_ENV+= ac_cv_prog_MOCQT4=${LOCALBASE}/bin/moc-qt4
USE_QT4= gui corelib xml qtestlib moc_build
-# It requires poppler/splash to be built unless you disable splash backend
-# support to allow you use BUILD_WRKSRC here. It seems that splash backend
-# can read more PDF files than without, tested with demos's poppler_qt4viewer.
-#BUILD_WRKSRC= ${WRKSRC}/qt4
+BUILD_WRKSRC= ${WRKSRC}/qt4
INSTALL_WRKSRC= ${WRKSRC}/qt4
.else
CONFIGURE_ARGS+=--disable-poppler-qt4
.endif
.if ${SLAVEPORT}=="utils"
-LIB_DEPENDS+= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib
+LIB_DEPENDS+= poppler-glib:${PORTSDIR}/graphics/poppler-glib
CONFIGURE_ARGS+=--enable-utils
-CONFLICTS= xpdf-[0-9]*
BUILD_WRKSRC= ${WRKSRC}/utils
INSTALL_WRKSRC= ${WRKSRC}/utils
-MAN1= pdffonts.1 pdfimages.1 pdfinfo.1 pdfseparate.1 pdftocairo.1 \
- pdftohtml.1 pdftops.1 pdftotext.1 pdftoppm.1 pdfunite.1
+MAN1= pdfdetach.1 pdffonts.1 pdfimages.1 pdfinfo.1 pdfseparate.1 \
+ pdftocairo.1 pdftohtml.1 pdftops.1 pdftotext.1 pdftoppm.1 \
+ pdfunite.1
.else
CONFIGURE_ARGS+=--disable-utils
.endif
@@ -85,19 +81,19 @@ CONFIGURE_ARGS+=--disable-poppler-glib \
--disable-poppler-qt4 \
--disable-utils
-.if defined(WITHOUT_CAIRO)
+.if ${PORT_OPTIONS:MCAIRO}
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
+PLIST_SUB+= CAIRO=""
+.else
CONFIGURE_ARGS+=--disable-cairo-output
PLIST_SUB+= CAIRO="@comment "
-.else
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-PLIST_SUB+= CAIRO=""
.endif
-.if defined(WITHOUT_OPENJPEG)
-CONFIGURE_ARGS+=--disable-libopenjpeg
-.else
+.if ${PORT_OPTIONS:MOPENJPEG}
CONFIGURE_ARGS+=--enable-libopenjpeg
-LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
+LIB_DEPENDS+= openjpeg:${PORTSDIR}/graphics/openjpeg
+.else
+CONFIGURE_ARGS+=--disable-libopenjpeg
.endif
.endif
@@ -105,15 +101,12 @@ post-patch:
.if ${CXX:M*clang*} && ${CXXFLAGS:M-stdlib=libc++}
@${REINPLACE_CMD} '/CXXFLAGS.*-ansi/d' ${WRKSRC}/configure
.endif
- @${REINPLACE_CMD} -e 's|-version-info 19:0:0|-version-info 18:0:0|g' \
+ @${REINPLACE_CMD} -e 's|-version-info 35:0:0|-version-info 34:0:0|g' \
${WRKSRC}/poppler/Makefile.in
.if defined(SLAVEPORT) && ${SLAVEPORT}=="qt4"
@${REINPLACE_CMD} -e 's|MOCQT4=`.*|MOCQT4="${LOCALBASE}/bin/moc-qt4"|' \
${WRKSRC}/configure
.endif
- # A fix for bug 52193 (fixed upstream at poppler-0.20)
- @${REINPLACE_CMD} -e 's:poppler/poppler-config.h:poppler-config.h:' \
- ${WRKSRC}/goo/*.h ${WRKSRC}/splash/*.h
post-install:
.if defined(SLAVEPORT)