aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /graphics/poppler
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'graphics/poppler')
-rw-r--r--graphics/poppler/Makefile13
-rw-r--r--graphics/poppler/distinfo5
-rw-r--r--graphics/poppler/files/patch-glib_Makefile.in40
-rw-r--r--graphics/poppler/files/patch-qt4_src_Makefile.in28
-rw-r--r--graphics/poppler/pkg-plist26
5 files changed, 71 insertions, 41 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index d76bcbb8ab1c..1928a9219b7a 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -3,11 +3,11 @@
# Whom: marcus@FreeBSD.org
#
# $FreeBSD$
-# $MCom: ports/graphics/poppler/Makefile,v 1.58 2010/03/14 22:08:42 kwm Exp $
+# $MCom: ports/graphics/poppler/Makefile,v 1.66 2010/11/17 15:03:00 kwm Exp $
#
PORTNAME= poppler
-PORTVERSION= 0.12.4
+PORTVERSION= 0.14.5
PORTREVISION?= 0
CATEGORIES= graphics print
MASTER_SITES= http://poppler.freedesktop.org/
@@ -20,9 +20,12 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
lcms.1:${PORTSDIR}/graphics/lcms
RUN_DEPENDS= poppler-data>0:${PORTSDIR}/graphics/poppler-data
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget libxml2 ltverhack
USE_AUTOTOOLS= libtool:22
+MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-zlib \
--enable-xpdf-headers \
@@ -40,7 +43,7 @@ OPTIONS= CAIRO "Enable cairo output backend" on \
.include <bsd.port.pre.mk>
.if defined(SLAVEPORT)
-LIB_DEPENDS+= poppler.5:${PORTSDIR}/graphics/poppler
+LIB_DEPENDS+= poppler.6:${PORTSDIR}/graphics/poppler
.if ${SLAVEPORT}=="gtk"
CONFIGURE_ARGS+=--enable-poppler-glib
@@ -110,11 +113,13 @@ LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|7:0:0|6:0:0|' ${WRKSRC}/poppler/Makefile.in
+
.if defined(SLAVEPORT) && ${SLAVEPORT}=="qt"
@${REINPLACE_CMD} -e 's|/usr/local/qt/include|${LOCALBASE}/include|; \
+ s|$$QTDIR|${QT_PREFIX}|; \
s|/usr/local/qt/lib|${LOCALBASE}/lib|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|$$QTDIR|${QT_PREFIX}|' ${WRKSRC}/configure
.endif
.if defined(SLAVEPORT) && ${SLAVEPORT}=="qt4"
@${REINPLACE_CMD} -e 's|MOCQT4=`.*|MOCQT4="${LOCALBASE}/bin/moc-qt4"|' \
diff --git a/graphics/poppler/distinfo b/graphics/poppler/distinfo
index fe24669ee9cd..d34cf4192e34 100644
--- a/graphics/poppler/distinfo
+++ b/graphics/poppler/distinfo
@@ -1,3 +1,2 @@
-MD5 (poppler-0.12.4.tar.gz) = 4155346f9369b192569ce9184ff73e43
-SHA256 (poppler-0.12.4.tar.gz) = 2afa2a54bd4ccb09e92f82b64bcafa95d39a404a3b3db9d6a5fcad0e0229857a
-SIZE (poppler-0.12.4.tar.gz) = 1674400
+SHA256 (poppler-0.14.5.tar.gz) = c805317c4c1a7080098ae8c7c2a1c1b8e2c784858fc2e04941878eeb8164814c
+SIZE (poppler-0.14.5.tar.gz) = 1798194
diff --git a/graphics/poppler/files/patch-glib_Makefile.in b/graphics/poppler/files/patch-glib_Makefile.in
index 94d7703cd62b..4afb4b2aa878 100644
--- a/graphics/poppler/files/patch-glib_Makefile.in
+++ b/graphics/poppler/files/patch-glib_Makefile.in
@@ -1,40 +1,42 @@
---- glib/Makefile.in.orig 2008-03-24 09:03:54.000000000 -0400
-+++ glib/Makefile.in 2008-03-24 09:04:38.000000000 -0400
-@@ -66,7 +66,6 @@
- @BUILD_CAIRO_OUTPUT_TRUE@am__DEPENDENCIES_2 = $(top_builddir)/poppler/libpoppler-cairo.la \
- @BUILD_CAIRO_OUTPUT_TRUE@ $(am__DEPENDENCIES_1)
+--- glib/Makefile.in.orig 2010-08-14 16:50:48.000000000 +0200
++++ glib/Makefile.in 2010-08-14 16:50:48.000000000 +0200
+@@ -82,7 +82,6 @@
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
libpoppler_glib_la_DEPENDENCIES = \
-- $(top_builddir)/poppler/libpoppler.la $(am__DEPENDENCIES_1) \
+- $(top_builddir)/poppler/libpoppler.la \
+ $(top_builddir)/poppler/libpoppler-cairo.la \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2)
- am__objects_1 = poppler-enums.lo
-@@ -80,7 +79,6 @@
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+@@ -105,8 +104,7 @@
@BUILD_WITH_GDK_TRUE@ test-poppler-glib.$(OBJEXT)
test_poppler_glib_OBJECTS = $(am_test_poppler_glib_OBJECTS)
@BUILD_WITH_GDK_TRUE@test_poppler_glib_DEPENDENCIES = \
-@BUILD_WITH_GDK_TRUE@ $(top_builddir)/poppler/libpoppler.la \
- @BUILD_WITH_GDK_TRUE@ libpoppler-glib.la $(am__DEPENDENCIES_1) \
+-@BUILD_WITH_GDK_TRUE@ libpoppler-glib.la $(am__DEPENDENCIES_1) \
++@BUILD_WITH_GDK_TRUE@ $(am__DEPENDENCIES_1) \
@BUILD_WITH_GDK_TRUE@ $(am__DEPENDENCIES_1) \
- @BUILD_WITH_GDK_TRUE@ $(am__DEPENDENCIES_1) \
-@@ -295,7 +293,7 @@
- @BUILD_CAIRO_OUTPUT_TRUE@ $(top_builddir)/poppler/libpoppler-cairo.la \
- @BUILD_CAIRO_OUTPUT_TRUE@ $(CAIRO_LIBS)
-
+ @BUILD_WITH_GDK_TRUE@ $(am__DEPENDENCIES_1)
+ DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir) -I$(top_builddir)/poppler
+@@ -386,7 +384,7 @@
+ top_srcdir = @top_srcdir@
+ win32_libs = @win32_libs@
+ AM_LDFLAGS = @auto_import_flags@
-SUBDIRS = . reference demo
+SUBDIRS = . reference
INCLUDES = \
-DG_LOG_DOMAIN=\"Poppler\" \
-I$(top_srcdir) \
-@@ -336,7 +334,7 @@
+@@ -439,7 +437,7 @@
poppler-private.h
libpoppler_glib_la_LIBADD = \
- $(top_builddir)/poppler/libpoppler.la \
-+ -lpoppler \
++ -lpoppler \
+ $(top_builddir)/poppler/libpoppler-cairo.la \
$(POPPLER_GLIB_LIBS) \
$(GDK_LIBS) \
- $(FREETYPE_LIBS) \
-@@ -348,7 +346,7 @@
+@@ -451,7 +449,7 @@
@BUILD_WITH_GDK_TRUE@ test-poppler-glib.cc
@BUILD_WITH_GDK_TRUE@test_poppler_glib_LDADD = \
diff --git a/graphics/poppler/files/patch-qt4_src_Makefile.in b/graphics/poppler/files/patch-qt4_src_Makefile.in
index e9f0ee2e3749..916eabc22f88 100644
--- a/graphics/poppler/files/patch-qt4_src_Makefile.in
+++ b/graphics/poppler/files/patch-qt4_src_Makefile.in
@@ -1,19 +1,19 @@
---- qt4/src/Makefile.in.orig 2008-07-02 14:06:32.000000000 -0500
-+++ qt4/src/Makefile.in 2008-07-02 14:07:35.000000000 -0500
-@@ -62,7 +62,6 @@
+--- qt4/src/Makefile.in.orig 2010-07-07 14:22:29.000000000 +0200
++++ qt4/src/Makefile.in 2010-07-07 14:23:40.000000000 +0200
+@@ -79,7 +79,6 @@
LTLIBRARIES = $(lib_LTLIBRARIES)
am__DEPENDENCIES_1 =
libpoppler_qt4_la_DEPENDENCIES = \
-- $(top_builddir)/poppler/libpoppler.la $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) $(am__append_1)
+- $(top_builddir)/poppler/libpoppler.la \
+ $(top_builddir)/poppler/libpoppler-arthur.la \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
am_libpoppler_qt4_la_OBJECTS = poppler-document.lo poppler-page.lo \
- poppler-fontinfo.lo poppler-embeddedfile.lo poppler-textbox.lo \
-@@ -303,7 +302,7 @@
- poppler-export.h \
- poppler-private.h
+@@ -384,7 +383,7 @@
+ poppler-page-transition-private.h
--libpoppler_qt4_la_LIBADD = $(top_builddir)/poppler/libpoppler.la \
-+libpoppler_qt4_la_LIBADD = -lpoppler \
- $(FONTCONFIG_LIBS) $(POPPLER_QT4_LIBS) $(am__append_1)
- libpoppler_qt4_la_LDFLAGS = -version-info 3:0:0
- all: all-am
+ libpoppler_qt4_la_LIBADD = \
+- $(top_builddir)/poppler/libpoppler.la \
++ -lpoppler \
+ $(top_builddir)/poppler/libpoppler-arthur.la \
+ $(FONTCONFIG_LIBS) \
+ $(POPPLER_QT4_LIBS)
diff --git a/graphics/poppler/pkg-plist b/graphics/poppler/pkg-plist
index 5ccd2f4ab8da..92af8cb0eaf5 100644
--- a/graphics/poppler/pkg-plist
+++ b/graphics/poppler/pkg-plist
@@ -3,6 +3,7 @@ include/poppler/Array.h
include/poppler/BuiltinFont.h
include/poppler/BuiltinFontTables.h
include/poppler/CMap.h
+include/poppler/CachedFile.h
include/poppler/Catalog.h
include/poppler/CharCodeToUnicode.h
include/poppler/CharTypes.h
@@ -26,6 +27,7 @@ include/poppler/JArithmeticDecoder.h
include/poppler/JBIG2Stream.h
include/poppler/Lexer.h
include/poppler/Link.h
+include/poppler/LocalPDFDocBuilder.h
include/poppler/Movie.h
include/poppler/NameToCharCode.h
include/poppler/NameToUnicodeTable.h
@@ -34,7 +36,9 @@ include/poppler/OptionalContent.h
include/poppler/Outline.h
include/poppler/OutputDev.h
include/poppler/PDFDoc.h
+include/poppler/PDFDocBuilder.h
include/poppler/PDFDocEncoding.h
+include/poppler/PDFDocFactory.h
include/poppler/PSOutputDev.h
include/poppler/PSTokenizer.h
include/poppler/Page.h
@@ -43,9 +47,12 @@ include/poppler/Parser.h
include/poppler/PopplerCache.h
include/poppler/PreScanOutputDev.h
include/poppler/ProfileData.h
+include/poppler/Rendition.h
include/poppler/SecurityHandler.h
include/poppler/Sound.h
include/poppler/SplashOutputDev.h
+include/poppler/StdinCachedFile.h
+include/poppler/StdinPDFDocBuilder.h
include/poppler/Stream-CCITT.h
include/poppler/Stream.h
include/poppler/TextOutputDev.h
@@ -58,6 +65,15 @@ include/poppler/UnicodeMapTables.h
include/poppler/UnicodeTypeTable.h
include/poppler/XRef.h
include/poppler/XpdfPluginAPI.h
+include/poppler/cpp/poppler-document.h
+include/poppler/cpp/poppler-embedded-file.h
+include/poppler/cpp/poppler-font.h
+include/poppler/cpp/poppler-global.h
+include/poppler/cpp/poppler-page-transition.h
+include/poppler/cpp/poppler-page.h
+include/poppler/cpp/poppler-rectangle.h
+include/poppler/cpp/poppler-toc.h
+include/poppler/cpp/poppler-version.h
include/poppler/fofi/FoFiBase.h
include/poppler/fofi/FoFiEncodings.h
include/poppler/fofi/FoFiTrueType.h
@@ -70,6 +86,8 @@ include/poppler/goo/GooMutex.h
include/poppler/goo/GooString.h
include/poppler/goo/GooTimer.h
include/poppler/goo/GooVector.h
+include/poppler/goo/ImgWriter.h
+include/poppler/goo/JpegWriter.h
include/poppler/goo/PNGWriter.h
include/poppler/goo/gfile.h
include/poppler/goo/gmem.h
@@ -99,14 +117,20 @@ include/poppler/splash/SplashT1FontFile.h
include/poppler/splash/SplashTypes.h
include/poppler/splash/SplashXPath.h
include/poppler/splash/SplashXPathScanner.h
+lib/libpoppler-cpp.a
+lib/libpoppler-cpp.la
+lib/libpoppler-cpp.so
+lib/libpoppler-cpp.so.0
lib/libpoppler.a
lib/libpoppler.la
lib/libpoppler.so
-lib/libpoppler.so.5
+lib/libpoppler.so.6
%%CAIRO%%libdata/pkgconfig/poppler-cairo.pc
+libdata/pkgconfig/poppler-cpp.pc
libdata/pkgconfig/poppler-splash.pc
libdata/pkgconfig/poppler.pc
@dirrm include/poppler/splash
@dirrm include/poppler/goo
@dirrm include/poppler/fofi
+@dirrm include/poppler/cpp
@dirrm include/poppler