aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-05 09:09:18 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-05 12:23:28 +0000
commitd8d6d6af0c7555b0bb2af494ba2b74c92bb7db92 (patch)
tree9c81910cc3c9d5bc340c1aadcb6e6c0daa5d6904 /graphics/poppler
parent6177ada8583c3bc834b7dc6c5fb418d4e8728d0b (diff)
downloadports-d8d6d6af0c7555b0bb2af494ba2b74c92bb7db92.tar.gz
ports-d8d6d6af0c7555b0bb2af494ba2b74c92bb7db92.zip
graphics/poppler: make boost a build-time dependency
Poppler uses Boost small-vectors for efficiency (over std::vector) when the Splash renderer is enabled. Small-vectors are header-only, so there is no need to depend on the whole boost-libs at runtime. The PR asks to drop Boost entirely; we're not going to do that, but as a build-dep it avoids installed-size bloat. Bump PORTREVISION also of related ports to make sure they are rebuilt; don't need to re-do all consumers because Boost was not linked anyway. PR: 256821
Diffstat (limited to 'graphics/poppler')
-rw-r--r--graphics/poppler/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index bfa291c0f17a..bbb54dad755f 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -2,6 +2,7 @@
PORTNAME= poppler
DISTVERSION= 21.06.1
+PORTREVISION= 1
CATEGORIES= graphics print
MASTER_SITES= https://poppler.freedesktop.org/
@@ -17,8 +18,8 @@ LIB_DEPENDS= libnspr4.so:devel/nspr \
libtiff.so:graphics/tiff \
libfreetype.so:print/freetype2 \
libnss3.so:security/nss \
- libfontconfig.so:x11-fonts/fontconfig \
- libboost_system.so:devel/boost-libs
+ libfontconfig.so:x11-fonts/fontconfig
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/container/small_vector.hpp:devel/boost-libs
RUN_DEPENDS= poppler-data>0:graphics/poppler-data
USES= compiler:c++11-lang cpe cmake:insource gnome jpeg libtool \