aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-PyOpenGL
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-09 19:26:26 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-09 19:26:26 +0000
commit96fdc0d6069b67ac715512eef5514f489af5e0af (patch)
treea2668346a9d81766a7c1b5ccb271655915db5c40 /graphics/py-PyOpenGL
parentdde5a8426c978aeec99119a3ca44090624a06cdb (diff)
downloadports-96fdc0d6069b67ac715512eef5514f489af5e0af.tar.gz
ports-96fdc0d6069b67ac715512eef5514f489af5e0af.zip
graphics/py-opengl{-accelerate}: 3.0.1 -> 3.1.0, change to PyPI naming
- upgrade fixes the use of the port - py-opengl -> py-PyOpenGL - py-opengl-accelerate -> py-PyOpenGL-accelerate PR: 205472 Submitted by: matthew@reztek.cz Reviewed by: koobs
Notes
Notes: svn path=/head/; revision=414888
Diffstat (limited to 'graphics/py-PyOpenGL')
-rw-r--r--graphics/py-PyOpenGL/Makefile35
-rw-r--r--graphics/py-PyOpenGL/distinfo2
-rw-r--r--graphics/py-PyOpenGL/pkg-descr21
3 files changed, 58 insertions, 0 deletions
diff --git a/graphics/py-PyOpenGL/Makefile b/graphics/py-PyOpenGL/Makefile
new file mode 100644
index 000000000000..41bd8503cf76
--- /dev/null
+++ b/graphics/py-PyOpenGL/Makefile
@@ -0,0 +1,35 @@
+# Created by: Randall Hopper <aa8vb@ipass.net>
+# $FreeBSD$
+
+PORTNAME= PyOpenGL
+PORTVERSION= 3.1.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+#DISTNAME= PyOpenGL-${PORTVERSION}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= OpenGL (and related library) interface for Python
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= TKINTER
+OPTIONS_DEFAULT= TKINTER
+TKINTER_DESC= Build with tkinter for X support
+
+USES= dos2unix python
+USE_GL= glut
+USE_PYTHON= distutils autoplist
+
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<malloc\.h>|<stdlib.h>|g'
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
+ ${REINPLACE_CMD} -e 's|posix |posix|g' ${WRKSRC}/OpenGL/__init__.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-PyOpenGL/distinfo b/graphics/py-PyOpenGL/distinfo
new file mode 100644
index 000000000000..6103f1e8e17f
--- /dev/null
+++ b/graphics/py-PyOpenGL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PyOpenGL-3.1.0.tar.gz) = 9b47c5c3a094fa518ca88aeed35ae75834d53e4285512c61879f67a48c94ddaf
+SIZE (PyOpenGL-3.1.0.tar.gz) = 1172688
diff --git a/graphics/py-PyOpenGL/pkg-descr b/graphics/py-PyOpenGL/pkg-descr
new file mode 100644
index 000000000000..368694cfce50
--- /dev/null
+++ b/graphics/py-PyOpenGL/pkg-descr
@@ -0,0 +1,21 @@
+PyOpenGL is an interface between the Python programming language and the OpenGL
+library (and related libraries). The package provides interfaces to:
+
+ - The OpenGL library itself, which is a three-dimensional graphical
+ rendering interface. For more information, visit
+ http://www.opengl.org.
+
+ - The GLU library which provides access to routines for doing
+ quadrics, tesselation etc.
+
+ - The GLUT (GL UTilitity) library from Mark Kilgard, which provides a
+ windowing environment.
+
+ - The Togl (Tk/OpenGL) widget from Brian Paul and Ben Benderson (an
+ alternative to GLUT which interfaces to Tk).
+
+The Python bindings offer some value-added tools in addition to the
+standard API, including support for fast processing of arrays of
+coordinates, trackball support, etc.
+
+WWW: http://pyopengl.sourceforge.net/