aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-cairo
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-08 15:05:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-08 15:05:48 +0000
commit8157e9f8001110ec707b895aa362d7abc4f5c948 (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /graphics/py-cairo
parent671d1d9bd194a574d3933765d1cc084536ad8e91 (diff)
downloadports-8157e9f8001110ec707b895aa362d7abc4f5c948.tar.gz
ports-8157e9f8001110ec707b895aa362d7abc4f5c948.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Notes
Notes: svn path=/head/; revision=383571
Diffstat (limited to 'graphics/py-cairo')
-rw-r--r--graphics/py-cairo/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/graphics/py-cairo/Makefile b/graphics/py-cairo/Makefile
index fe10cd4d6a17..73f3c8e3fab6 100644
--- a/graphics/py-cairo/Makefile
+++ b/graphics/py-cairo/Makefile
@@ -13,7 +13,7 @@ DISTNAME= py2${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python 2 bindings for Cairo
-USES= pkgconfig python:2 shebangfix tar:bzip2
+USES= pkgconfig python:2 shebangfix tar:bzip2 waf
USE_GNOME= cairo
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -24,16 +24,6 @@ python_OLD_CMD?= /usr/bin/env python
python_CMD?= ${LOCALBASE}/bin/python2
SHEBANG_FILES= examples/*.py examples/*/*.py test/*.py
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
- ./waf configure
-
-do-build:
- @cd ${WRKSRC} && ${PYTHON_CMD} ./waf
-
-do-install:
- cd ${WRKSRC} && ${PYTHON_CMD} ./waf install --destdir=${STAGEDIR}
-
post-install:
@cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
-d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}