aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-cartopy
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-01 19:35:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-01 19:35:09 +0000
commit96587da298ad3bc55de4793817851af9b6c8a374 (patch)
tree0ad528b37aca85cc21dee84855d1469c529df274 /graphics/py-cartopy
parentb9eb43ad98b7497c7eb95ad92669b559cc59637f (diff)
downloadports-96587da298ad3bc55de4793817851af9b6c8a374.tar.gz
ports-96587da298ad3bc55de4793817851af9b6c8a374.zip
Remove PYNUMPY and PY_PILLOW
Notes
Notes: svn path=/head/; revision=563660
Diffstat (limited to 'graphics/py-cartopy')
-rw-r--r--graphics/py-cartopy/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/py-cartopy/Makefile b/graphics/py-cartopy/Makefile
index 7056667a3fa9..4f586e020344 100644
--- a/graphics/py-cartopy/Makefile
+++ b/graphics/py-cartopy/Makefile
@@ -17,10 +17,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
BUILD_DEPENDS= geos>=3.3.3:graphics/geos \
proj>=4.9.0,1:graphics/proj \
- ${PYNUMPY}
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR}
LIB_DEPENDS= libgeos.so:graphics/geos \
libproj.so:graphics/proj
-RUN_DEPENDS= ${PYNUMPY} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyshp>=1.1.4:devel/py-pyshp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Shapely>=1.5.6:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${PY_FLAVOR}
@@ -37,10 +37,10 @@ PLOTTING_DESC= Plotting support
EPSG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyepsg>=0:graphics/py-pyepsg@${PY_FLAVOR}
OWS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}OWSLib>=0.8.11:graphics/py-OWSLib@${PY_FLAVOR} \
- ${PY_PILLOW}
+ ${PYTHON_PKGNAMEPREFIX}pillow>=1.7.8:graphics/py-pillow@${PY_FLAVOR}
PLOTTING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdal>=1.10.0:graphics/py-gdal@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.1:math/py-matplotlib@${PY_FLAVOR} \
- ${PY_PILLOW} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=1.7.8:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.10:science/py-scipy@${PY_FLAVOR}
.include <bsd.port.mk>