aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graph-dot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-05 14:16:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-05 14:16:41 +0000
commite5deafa8f4d5a25cdaae1d4b83dbcbeb1e46c84c (patch)
tree988c54f8379f3c8aa94a59b5aad09652967cb28b /graphics/py-graph-dot
parentd6dc2addd21df5c03c224921af6ff1c18f89e667 (diff)
downloadports-e5deafa8f4d5a25cdaae1d4b83dbcbeb1e46c84c.tar.gz
ports-e5deafa8f4d5a25cdaae1d4b83dbcbeb1e46c84c.zip
Notes
Diffstat (limited to 'graphics/py-graph-dot')
-rw-r--r--graphics/py-graph-dot/Makefile43
-rw-r--r--graphics/py-graph-dot/distinfo3
-rw-r--r--graphics/py-graph-dot/pkg-descr5
-rw-r--r--graphics/py-graph-dot/pkg-plist46
4 files changed, 97 insertions, 0 deletions
diff --git a/graphics/py-graph-dot/Makefile b/graphics/py-graph-dot/Makefile
new file mode 100644
index 000000000000..7b97ab81a0a9
--- /dev/null
+++ b/graphics/py-graph-dot/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: py-graph
+# Date created: 2008-08-29
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graph
+PORTVERSION= 1.0.0
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-graph-${PORTVERSION}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A library for working with graphs in Python
+
+BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+
+PROJECTHOST= python-graph
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-graph
+
+WRKSRC= ${WRKDIR}/${PYDISTUTILS_PKGNAME}
+
+USE_BZIP2= yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-graph-dot/distinfo b/graphics/py-graph-dot/distinfo
new file mode 100644
index 000000000000..451f4bf272aa
--- /dev/null
+++ b/graphics/py-graph-dot/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-graph-1.0.0.tar.bz2) = a9e4113446225a473f95f02779628de8
+SHA256 (python-graph-1.0.0.tar.bz2) = fde61fe2e6d9ec7e5dc36324eb80c718e01eaf8e7f2cc1f6f802dde6b0ec2e7d
+SIZE (python-graph-1.0.0.tar.bz2) = 29737
diff --git a/graphics/py-graph-dot/pkg-descr b/graphics/py-graph-dot/pkg-descr
new file mode 100644
index 000000000000..ccab5a868b40
--- /dev/null
+++ b/graphics/py-graph-dot/pkg-descr
@@ -0,0 +1,5 @@
+A library for working with graphs in Python.
+It provides a suitable data structure for representing graphs
+and a whole set of important algorithms.
+
+WWW: http://code.google.com/p/python-graph/
diff --git a/graphics/py-graph-dot/pkg-plist b/graphics/py-graph-dot/pkg-plist
new file mode 100644
index 000000000000..032f4324a5d4
--- /dev/null
+++ b/graphics/py-graph-dot/pkg-plist
@@ -0,0 +1,46 @@
+%%PYTHON_SITELIBDIR%%/graph/__init__.py
+%%PYTHON_SITELIBDIR%%/graph/__init__.pyc
+%%PYTHON_SITELIBDIR%%/graph/__init__.pyo
+%%PYTHON_SITELIBDIR%%/graph/accessibility.py
+%%PYTHON_SITELIBDIR%%/graph/accessibility.pyc
+%%PYTHON_SITELIBDIR%%/graph/accessibility.pyo
+%%PYTHON_SITELIBDIR%%/graph/generators.py
+%%PYTHON_SITELIBDIR%%/graph/generators.pyc
+%%PYTHON_SITELIBDIR%%/graph/generators.pyo
+%%PYTHON_SITELIBDIR%%/graph/minmax.py
+%%PYTHON_SITELIBDIR%%/graph/minmax.pyc
+%%PYTHON_SITELIBDIR%%/graph/minmax.pyo
+%%PYTHON_SITELIBDIR%%/graph/readwrite.py
+%%PYTHON_SITELIBDIR%%/graph/readwrite.pyc
+%%PYTHON_SITELIBDIR%%/graph/readwrite.pyo
+%%PYTHON_SITELIBDIR%%/graph/searching.py
+%%PYTHON_SITELIBDIR%%/graph/searching.pyc
+%%PYTHON_SITELIBDIR%%/graph/searching.pyo
+%%PYTHON_SITELIBDIR%%/graph/sorting.py
+%%PYTHON_SITELIBDIR%%/graph/sorting.pyc
+%%PYTHON_SITELIBDIR%%/graph/sorting.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/graph
+%%PORTDOCS%%%%DOCSDIR%%/api-objects.txt
+%%PORTDOCS%%%%DOCSDIR%%/class-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/crarr.png
+%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
+%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
+%%PORTDOCS%%%%DOCSDIR%%/graph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.accessibility-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.generators-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.graph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.minmax-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.readwrite-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.searching-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.sorting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/help.html
+%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/redirect.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%