aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graphviz
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-02-13 01:44:22 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-02-13 01:44:22 +0000
commitba553c41978b461df5a9165b1e1fc8b92f8d3a7c (patch)
treea5d1379f2b8f380d741d0e421c5816e7710f91f6 /graphics/py-graphviz
parent14c6afdb69ea9fb570cbfb159d6105eae5d9a54d (diff)
downloadports-ba553c41978b461df5a9165b1e1fc8b92f8d3a7c.tar.gz
ports-ba553c41978b461df5a9165b1e1fc8b92f8d3a7c.zip
- Update to 0.99.1
PR: ports/131509 Submitted by: Yi-Jheng Lin <yzlin at cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=228171
Diffstat (limited to 'graphics/py-graphviz')
-rw-r--r--graphics/py-graphviz/Makefile9
-rw-r--r--graphics/py-graphviz/distinfo6
-rw-r--r--graphics/py-graphviz/files/patch-setup.py31
-rw-r--r--graphics/py-graphviz/pkg-plist19
4 files changed, 42 insertions, 23 deletions
diff --git a/graphics/py-graphviz/Makefile b/graphics/py-graphviz/Makefile
index 8f730b85f062..04d46958bf20 100644
--- a/graphics/py-graphviz/Makefile
+++ b/graphics/py-graphviz/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
PORTNAME= graphviz
-PORTVERSION= 0.33
-PORTREVISION= 2
+PORTVERSION= 0.99.1
CATEGORIES= graphics python
-MASTER_SITES= http://networkx.lanl.gov/download/pygraphviz/
+MASTER_SITES= CHEESESHOP \
+ http://networkx.lanl.gov/download/pygraphviz/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pygraphviz-${PORTVERSION}
@@ -21,7 +21,8 @@ RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= pygraphviz
-PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+; \
diff --git a/graphics/py-graphviz/distinfo b/graphics/py-graphviz/distinfo
index c6a18078180e..a2aea63ccc49 100644
--- a/graphics/py-graphviz/distinfo
+++ b/graphics/py-graphviz/distinfo
@@ -1,3 +1,3 @@
-MD5 (pygraphviz-0.33.tar.gz) = 2e89b8ec52be5f91b47f2b904c590f7a
-SHA256 (pygraphviz-0.33.tar.gz) = bbc277fa4c2b49d4ea836163a7482a3e8fa55537c7c18e79325e5face31c64ea
-SIZE (pygraphviz-0.33.tar.gz) = 66998
+MD5 (pygraphviz-0.99.1.tar.gz) = 5381633f9538804b24046eb96474668d
+SHA256 (pygraphviz-0.99.1.tar.gz) = 7c4218a8fae6f8b7627c322b328940e90b6afc6c10a5efc4f63ad7c5b4964002
+SIZE (pygraphviz-0.99.1.tar.gz) = 85220
diff --git a/graphics/py-graphviz/files/patch-setup.py b/graphics/py-graphviz/files/patch-setup.py
index 2418143d6264..3818670d4eed 100644
--- a/graphics/py-graphviz/files/patch-setup.py
+++ b/graphics/py-graphviz/files/patch-setup.py
@@ -1,11 +1,24 @@
---- setup.py.orig Sun Mar 12 23:09:05 2006
-+++ setup.py Sun Sep 24 15:05:50 2006
-@@ -25,7 +19,7 @@
+--- setup.py.orig
++++ setup.py
+@@ -20,8 +20,8 @@
+ print "To install, run 'python setup.py install'"
+ print
- # If setting the prefix failed you should attempt to set the prefix here:
- # prefix="/usr" # unix, Linux
--# prefix="/usr/local" # unix, alternate
-+prefix="%%LOCALBASE%%" # unix, alternate
- # prefix="/sw" # OSX, fink
- # prefix="/opt/local" # OSX, darwin-ports?
+-library_path=None
+-include_path=None
++#library_path=None
++#include_path=None
+
+ # If the setup script couldn't find your graphviz installation you can
+@@ -33,8 +33,8 @@
+ #include_path='/usr/include/graphviz'
+
+ # UNIX, Linux alternate
+-#library_path='/usr/local/lib/graphviz'
+-#include_path='/usr/local/include/graphviz'
++library_path='%%LOCALBASE%%/lib/graphviz'
++include_path='%%LOCALBASE%%/include/graphviz'
+
+ # Mac OS X (Fink)
+ #library_path='/sw/lib/graphviz'
diff --git a/graphics/py-graphviz/pkg-plist b/graphics/py-graphviz/pkg-plist
index 1da35ca13f16..09a02743d080 100644
--- a/graphics/py-graphviz/pkg-plist
+++ b/graphics/py-graphviz/pkg-plist
@@ -8,22 +8,27 @@
%%PYTHON_SITELIBDIR%%/pygraphviz/graphviz.py
%%PYTHON_SITELIBDIR%%/pygraphviz/graphviz.pyc
%%PYTHON_SITELIBDIR%%/pygraphviz/graphviz.pyo
+%%PYTHON_SITELIBDIR%%/pygraphviz/release.py
+%%PYTHON_SITELIBDIR%%/pygraphviz/release.pyc
+%%PYTHON_SITELIBDIR%%/pygraphviz/release.pyo
%%PYTHON_SITELIBDIR%%/pygraphviz/tests/__init__.py
%%PYTHON_SITELIBDIR%%/pygraphviz/tests/__init__.pyc
%%PYTHON_SITELIBDIR%%/pygraphviz/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pygraphviz/tests/attributes.txt
+%%PYTHON_SITELIBDIR%%/pygraphviz/tests/graph.txt
+%%PYTHON_SITELIBDIR%%/pygraphviz/tests/layout_draw.txt
+%%PYTHON_SITELIBDIR%%/pygraphviz/tests/subgraph.txt
%%PYTHON_SITELIBDIR%%/pygraphviz/tests/test.py
%%PYTHON_SITELIBDIR%%/pygraphviz/tests/test.pyc
%%PYTHON_SITELIBDIR%%/pygraphviz/tests/test.pyo
-%%DOCSDIR%%/API.txt
-%%DOCSDIR%%/Examples.txt
-%%DOCSDIR%%/FAQ.txt
-%%DOCSDIR%%/License.txt
-%%DOCSDIR%%/Readme.txt
-%%DOCSDIR%%/Tutorial.txt
+%%DOCSDIR%%/INSTALL.txt
+%%DOCSDIR%%/README.txt
+%%DOCSDIR%%/examples/attributes.py
+%%DOCSDIR%%/examples/django_simple.py
%%DOCSDIR%%/examples/miles.py
%%DOCSDIR%%/examples/simple.py
%%DOCSDIR%%/examples/star.py
-%%DOCSDIR%%/examples/miles.dat
+%%DOCSDIR%%/examples/subgraph.py
@dirrm %%PYTHON_SITELIBDIR%%/pygraphviz/tests
@dirrm %%PYTHON_SITELIBDIR%%/pygraphviz
@dirrm %%DOCSDIR%%/examples