aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-h3
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-26 21:17:42 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-26 21:17:42 +0000
commit4db6d8bad49ca397ca94f9ccc479d05bb05e9561 (patch)
tree19acbb936e6de25e513e2cd3061b5be03624a6bc /graphics/py-h3
parent444c5506f68b50a2685101532c8b4a08ae708cb1 (diff)
downloadports-4db6d8bad49ca397ca94f9ccc479d05bb05e9561.tar.gz
ports-4db6d8bad49ca397ca94f9ccc479d05bb05e9561.zip
Convert to test framework
Notes
Notes: svn path=/head/; revision=556362
Diffstat (limited to 'graphics/py-h3')
-rw-r--r--graphics/py-h3/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/py-h3/Makefile b/graphics/py-h3/Makefile
index 9d9b50664d7e..d592b88d0344 100644
--- a/graphics/py-h3/Makefile
+++ b/graphics/py-h3/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= cmake:devel/cmake \
ninja:devel/ninja \
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
LIB_DEPENDS= libh3.so:graphics/h3
+TEST_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= localbase:ldflags python
USE_PYTHON= autoplist concurrent cython distutils
@@ -30,4 +32,7 @@ NUMPY_DESC= NumPy support
NUMPY_RUN_DEPENDS= ${PYNUMPY}
+do-test:
+ cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs -v
+
.include <bsd.port.mk>