aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-imaging-handbook/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-08-14 10:44:18 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-08-14 10:44:18 +0000
commitfbc77569ab0a0b70ef121b5a1b31df57dfe04d76 (patch)
tree0220d6ea21bce7707bbc0cb954d221313fad8c7d /graphics/py-imaging-handbook/Makefile
parent15ad3f573e34d683f0d2094ed7a9e49956ff52f9 (diff)
downloadports-fbc77569ab0a0b70ef121b5a1b31df57dfe04d76.tar.gz
ports-fbc77569ab0a0b70ef121b5a1b31df57dfe04d76.zip
Notes
Diffstat (limited to 'graphics/py-imaging-handbook/Makefile')
-rw-r--r--graphics/py-imaging-handbook/Makefile37
1 files changed, 24 insertions, 13 deletions
diff --git a/graphics/py-imaging-handbook/Makefile b/graphics/py-imaging-handbook/Makefile
index 57c889c1f4e5..c51b9f2f0b50 100644
--- a/graphics/py-imaging-handbook/Makefile
+++ b/graphics/py-imaging-handbook/Makefile
@@ -6,28 +6,39 @@
#
PORTNAME= imaging-handbook
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= graphics
-MASTER_SITES= http://www.pythonware.com/library/pil/handbook/
+MASTER_SITES= http://www.pythonware.com/library/pil/handbook/ \
+ http://www.pythonware.com/images/ \
+ http://www.pythonware.com/
PKGNAMEPREFIX= py-
-DISTFILES= labdoc.css index.htm overview.htm concepts.htm \
- intro01.htm support.htm license.htm image.htm \
- imagechops.htm imagedraw.htm imageenhance.htm \
- imagefilter.htm imagefileio.htm imagefont.htm \
- imagepalette.htm imagesequence.htm imagestat.htm \
- imagetk.htm imagewin.htm psdraw.htm pilconvert.htm \
- pildriver.htm pilfile.htm pilfont.htm pilprint.htm \
- formats.htm decoder.htm
+DISTFILES= appendices.htm blank.gif blurb-works-1.2.gif concepts.htm \
+ concept1.gif getting-support.htm icon-works.gif \
+ image-file-formats.htm image.htm imagechops.htm \
+ imagecrackcode.htm imagedraw.htm imageenhance.htm \
+ imagefile.htm imagefileio.htm imagefilter.htm imagefont.htm \
+ imagepath.htm imagesequence.htm imagestat.htm imagetk.htm \
+ imagewin.htm index.htm introducing-pil.htm mailto-light.gif \
+ module-reference.htm pilconvert.htm pildriver.htm pilfile.htm \
+ pilfont.htm pilprint.htm preface.htm psdraw.htm pythonware.css \
+ remote-light.gif software-license.htm tools-reference.htm \
+ tutorial.htm writing-your-own-file-decoder.htm
MAINTAINER= john@coastalgeology.org
DIST_SUBDIR= pil
EXTRACT_ONLY=
-NO_BUILD= yes
+
+do-build:
+.for file in ${DISTFILES}
+ ${SED} 's|\.\./\.\./\.\./pythonware\.css|pythonware.css|g ; \
+ s|\.\./\.\./\.\./images/||g' \
+ ${DISTDIR}/${DIST_SUBDIR}/${file} > ${WRKDIR}/${file}
+.endfor
do-install:
@${MKDIR} ${PREFIX}/share/doc/PIL/handbook
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.css ${PREFIX}/share/doc/PIL/handbook
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.htm ${PREFIX}/share/doc/PIL/handbook
+ @cd ${WRKDIR} && ${INSTALL_DATA} ${DISTFILES} \
+ ${PREFIX}/share/doc/PIL/handbook
.include <bsd.port.mk>