aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-img2pdf/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
commit1bf9457272318a99eb550ee7603ef85903c36cea (patch)
tree30969701cc82a93abc61c62dd66cf03666bbe585 /graphics/py-img2pdf/Makefile
parentb4990c3eb608adca7aab250206f47b154ccd7711 (diff)
downloadports-1bf9457272318a99eb550ee7603ef85903c36cea.tar.gz
ports-1bf9457272318a99eb550ee7603ef85903c36cea.zip
Notes
Diffstat (limited to 'graphics/py-img2pdf/Makefile')
-rw-r--r--graphics/py-img2pdf/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/graphics/py-img2pdf/Makefile b/graphics/py-img2pdf/Makefile
index 0264339bcb91..fe4645b8dde9 100644
--- a/graphics/py-img2pdf/Makefile
+++ b/graphics/py-img2pdf/Makefile
@@ -13,7 +13,8 @@ COMMENT= Convert images to PDF via direct JPEG inclusion
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34} \
+ ${PY_PILLOW}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdfrw>0:textproc/py-pdfrw@${PY_FLAVOR}
USES= python
@@ -21,17 +22,9 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
# Note: The tests only work with Python 3, see also:
# https://gitlab.mister-muffin.de/josch/img2pdf/issues/60
do-test:
@(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>