aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-moderngl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-20 16:09:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-20 21:06:47 +0000
commitfc70b79b196e18ed131c728f2f138fe2c04d1d46 (patch)
treeaef79b629754f502e1c233d6d268ea509915e338 /graphics/py-moderngl
parent980fd136e3f1ec9ea4773477b2c643e53981de9c (diff)
downloadports-fc70b79b196e18ed131c728f2f138fe2c04d1d46.tar.gz
ports-fc70b79b196e18ed131c728f2f138fe2c04d1d46.zip
Diffstat (limited to 'graphics/py-moderngl')
-rw-r--r--graphics/py-moderngl/Makefile28
-rw-r--r--graphics/py-moderngl/distinfo3
-rw-r--r--graphics/py-moderngl/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/py-moderngl/Makefile b/graphics/py-moderngl/Makefile
new file mode 100644
index 000000000000..ea2b34133fdd
--- /dev/null
+++ b/graphics/py-moderngl/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= moderngl
+DISTVERSION= 5.7.4
+CATEGORIES= graphics
+#MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= ModernGL: High performance rendering for Python 3
+WWW= https://moderngl.readthedocs.io/en/latest/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}glcontext>=2.3.6<3:graphics/py-glcontext@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # testsuite SEGVs, see https://github.com/moderngl/moderngl/issues/547
+
+USE_GITHUB= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/tests
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/moderngl/mgl${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/graphics/py-moderngl/distinfo b/graphics/py-moderngl/distinfo
new file mode 100644
index 000000000000..a9f64b518ad6
--- /dev/null
+++ b/graphics/py-moderngl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674242505
+SHA256 (moderngl-moderngl-5.7.4_GH0.tar.gz) = 1c3ded82f572d574a2116b55d6988fcd66776c809bdb09a42590ab678d612dca
+SIZE (moderngl-moderngl-5.7.4_GH0.tar.gz) = 2687476
diff --git a/graphics/py-moderngl/pkg-descr b/graphics/py-moderngl/pkg-descr
new file mode 100644
index 000000000000..814db167e6f4
--- /dev/null
+++ b/graphics/py-moderngl/pkg-descr
@@ -0,0 +1,7 @@
+ModernGL is a python wrapper over OpenGL 3.3+ core that simplifies the creation
+of simple graphics applications like scientific simulations, games or user
+interfaces. Usually, acquiring in-depth knowledge of OpenGL requires a steep
+learning curve. In contrast, ModernGL is easy to learn and use, moreover it is
+capable of rendering with high performance and quality, with less code written.
+The majority of the moderngl code base is also written in C++ for high
+performance.