aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-osmnet
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:09:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:09:35 +0000
commit0f480e41f508adabb55bc9786624c6512a35fbd3 (patch)
tree9ad551ef1d7fb5b39e7a3f7e630edeaf8c3313b2 /graphics/py-osmnet
parenta3da0fc69424e643af2d8d1f4d14bae3846aa356 (diff)
downloadports-0f480e41f508adabb55bc9786624c6512a35fbd3.tar.gz
ports-0f480e41f508adabb55bc9786624c6512a35fbd3.zip
Add py-osmnet 0.1.6
OSMnet offers tools to download street network data from OpenStreetMap and extract a graph network comprised of nodes and edges to be used in Pandana street network accessibility calculations. WWW: https://github.com/UDST/osmnet
Notes
Notes: svn path=/head/; revision=567604
Diffstat (limited to 'graphics/py-osmnet')
-rw-r--r--graphics/py-osmnet/Makefile27
-rw-r--r--graphics/py-osmnet/distinfo3
-rw-r--r--graphics/py-osmnet/pkg-descr5
3 files changed, 35 insertions, 0 deletions
diff --git a/graphics/py-osmnet/Makefile b/graphics/py-osmnet/Makefile
new file mode 100644
index 000000000000..73cad176e0b6
--- /dev/null
+++ b/graphics/py-osmnet/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= osmnet
+PORTVERSION= 0.1.6
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tools for the extraction of OpenStreetMap street network data
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopandas>=0.7:graphics/py-geopandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.23,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Shapely>=1.5:devel/py-shapely@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-osmnet/distinfo b/graphics/py-osmnet/distinfo
new file mode 100644
index 000000000000..833c9d7c3078
--- /dev/null
+++ b/graphics/py-osmnet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614794176
+SHA256 (osmnet-0.1.6.tar.gz) = 3cfb73317e59286797913e68ea3134205786ff1221111bbc5044b76ed8d26335
+SIZE (osmnet-0.1.6.tar.gz) = 27311
diff --git a/graphics/py-osmnet/pkg-descr b/graphics/py-osmnet/pkg-descr
new file mode 100644
index 000000000000..9bbdd85c8958
--- /dev/null
+++ b/graphics/py-osmnet/pkg-descr
@@ -0,0 +1,5 @@
+OSMnet offers tools to download street network data from OpenStreetMap and
+extract a graph network comprised of nodes and edges to be used in Pandana
+street network accessibility calculations.
+
+WWW: https://github.com/UDST/osmnet