aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pandana
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-24 01:32:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-24 01:32:22 +0000
commitedaa8d6eaf225fbb0217798536ad1555d261240a (patch)
tree3a635098b530e5f261aa873ccc43f91ff77b0516 /graphics/py-pandana
parent315634f10b8459756a55035ca56d74108ae1d3ef (diff)
downloadports-edaa8d6eaf225fbb0217798536ad1555d261240a.tar.gz
ports-edaa8d6eaf225fbb0217798536ad1555d261240a.zip
graphics/py-pandana: Broken on systems where OpenMP isn't enabled
Reported by: fallout Approved by: portmgr (blanket)
Diffstat (limited to 'graphics/py-pandana')
-rw-r--r--graphics/py-pandana/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/py-pandana/Makefile b/graphics/py-pandana/Makefile
index 94e45edaeac1..e9f6b43eb3c5 100644
--- a/graphics/py-pandana/Makefile
+++ b/graphics/py-pandana/Makefile
@@ -11,6 +11,10 @@ COMMENT= Python library for network analysis
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.25.2:lang/cython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \