aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pillow
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-05-18 16:23:35 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-05-18 16:23:35 +0000
commit1d479ec4cd6a62a70904a31173b159f7d13860cb (patch)
tree05b69b94aa3202b159944156e15d2fcee4a489f7 /graphics/py-pillow
parentb7431a96782a77ad20ee53649aadc030c1653d3a (diff)
downloadports-1d479ec4cd6a62a70904a31173b159f7d13860cb.tar.gz
ports-1d479ec4cd6a62a70904a31173b159f7d13860cb.zip
Create new port graphics/py3-pillow:
- This is a variant of graphics/py-pillow for Python 3.x. A separate port is needed until the ports tree gets VARIANTS support. The science/gramps port will soon be updated to a version which only supports python3, and it depends on py-pillow with python3. To allow people to only use packages directly (and not ports), the package building infrastructure needs to build 2 packages: py-pillow with python2 and py-pillow with python3. Since the ports tree doesn't yet have VARIANTS support, this is not yet possible without making a separate py3-pillow port. - Ensure graphics/py-pillow does not clobber USES and TKINTER_xxx_DEPENDS variables in slave port - Remove duplicate USES= line in graphics/py-pillow PR: 207040 Approved by: mat, adamw (mentors), koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D6433
Notes
Notes: svn path=/head/; revision=415455
Diffstat (limited to 'graphics/py-pillow')
-rw-r--r--graphics/py-pillow/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/graphics/py-pillow/Makefile b/graphics/py-pillow/Makefile
index 940c3edba2b3..4f74ac22711f 100644
--- a/graphics/py-pillow/Makefile
+++ b/graphics/py-pillow/Makefile
@@ -41,8 +41,8 @@ TIFF_VARS= PYDISTUTILS_BUILDARGS+=--enable-tiff
TIFF_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-tiff
TKINTER_USES= tk
-TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
-TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+TKINTER_BUILD_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+TKINTER_RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
TKINTER_VARS= PYDISTUTILS_BUILDARGS+="--enable-tcl --enable-tk --include-dirs=${TCL_INCLUDEDIR}:${TK_INCLUDEDIR}"
TKINTER_VARS_OFF= PYDISTUTILS_BUILDARGS+="--disable-tcl --disable-tk"
@@ -50,9 +50,8 @@ WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_VARS= PYDISTUTILS_BUILDARGS+=--enable-webp
WEBP_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-webp
-USES= cpe python
+USES?= cpe python
USE_GITHUB= yes
-USES= python
USE_PYTHON= autoplist concurrent distutils
GH_ACCOUNT= python-${PORTNAME}