aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pillow
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
commit4376dbbb58dab5a7bf7a8240ca39b562de78343b (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /graphics/py-pillow
parent6cb7ca00bb0a9a3aa67008824300ee8d16203a1b (diff)
downloadports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.tar.gz
ports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=472884
Diffstat (limited to 'graphics/py-pillow')
-rw-r--r--graphics/py-pillow/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/py-pillow/Makefile b/graphics/py-pillow/Makefile
index 15a68ead5b8f..9bc0165b3a13 100644
--- a/graphics/py-pillow/Makefile
+++ b/graphics/py-pillow/Makefile
@@ -14,8 +14,8 @@ LICENSE_NAME= Standard PIL License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
OPTIONS_DEFINE= FREETYPE JPEG JPEG2000 LCMS PNG TIFF TKINTER WEBP
OPTIONS_DEFAULT= FREETYPE JPEG JPEG2000 PNG TKINTER WEBP
@@ -47,8 +47,8 @@ TIFF_VARS= PYDISTUTILS_BUILDARGS+=--enable-tiff
TIFF_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-tiff
TKINTER_USES= tk
-TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${FLAVOR}
-TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${FLAVOR}
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
TKINTER_VARS= PYDISTUTILS_BUILDARGS+="--include-dirs=${TCL_INCLUDEDIR}:${TK_INCLUDEDIR}"
WEBP_LIB_DEPENDS= libwebp.so:graphics/webp