aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pycha
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-09 09:01:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-09 09:01:35 +0000
commit691acd38cc24a68992924aeb6684449a9ae685f9 (patch)
tree99c4a411ae14f664a2b9272f9af919e74b8e5155 /graphics/py-pycha
parent94eb5b829acde5155eb722bd3a98595237ff33f3 (diff)
downloadports-691acd38cc24a68992924aeb6684449a9ae685f9.tar.gz
ports-691acd38cc24a68992924aeb6684449a9ae685f9.zip
Pycha is a very simple Python package for drawing charts using the
great Cairo library. Its goals are: * Lightweight * Simple to use * Nice looking with default values * Customization It won't try to draw any possible chart on earth but draw the most common ones nicely. WWW: http://bitbucket.org/lgs/pycha/wiki/Home PR: ports/136597 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=237485
Diffstat (limited to 'graphics/py-pycha')
-rw-r--r--graphics/py-pycha/Makefile28
-rw-r--r--graphics/py-pycha/distinfo3
-rw-r--r--graphics/py-pycha/pkg-descr10
-rw-r--r--graphics/py-pycha/pkg-plist2
4 files changed, 43 insertions, 0 deletions
diff --git a/graphics/py-pycha/Makefile b/graphics/py-pycha/Makefile
new file mode 100644
index 000000000000..8a8cac5729c9
--- /dev/null
+++ b/graphics/py-pycha/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pycha
+# Date created: 08 July, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pycha
+PORTVERSION= 0.5.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A library for making charts with Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+OPTIONS= CAIRO "Add support for py-cairo" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CAIRO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/cairo:${PORTSDIR}/graphics/py-cairo
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-pycha/distinfo b/graphics/py-pycha/distinfo
new file mode 100644
index 000000000000..46f9d789b29a
--- /dev/null
+++ b/graphics/py-pycha/distinfo
@@ -0,0 +1,3 @@
+MD5 (pycha-0.5.0.tar.gz) = bb9038b89d001d7afea9b12b7f0edc11
+SHA256 (pycha-0.5.0.tar.gz) = b750eeff0a83996bf9f5d05ab678066bcff88784ff8643add3041d7c9d74916f
+SIZE (pycha-0.5.0.tar.gz) = 195610
diff --git a/graphics/py-pycha/pkg-descr b/graphics/py-pycha/pkg-descr
new file mode 100644
index 000000000000..d510e861151c
--- /dev/null
+++ b/graphics/py-pycha/pkg-descr
@@ -0,0 +1,10 @@
+Pycha is a very simple Python package for drawing charts using the
+great Cairo library. Its goals are:
+ * Lightweight
+ * Simple to use
+ * Nice looking with default values
+ * Customization
+It won't try to draw any possible chart on earth but draw the most
+common ones nicely.
+
+WWW: http://bitbucket.org/lgs/pycha/wiki/Home
diff --git a/graphics/py-pycha/pkg-plist b/graphics/py-pycha/pkg-plist
new file mode 100644
index 000000000000..6ea13162380d
--- /dev/null
+++ b/graphics/py-pycha/pkg-plist
@@ -0,0 +1,2 @@
+bin/chavier
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%