aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pydot
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-12-14 14:33:37 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-12-14 14:33:37 +0000
commit747b317dc1c54bfff398f1c54df46c9fa76e7d3b (patch)
treeabf602c78a942ad7427915590f8947623a65ce10 /graphics/py-pydot
parent193a3247a8384776d2de853fb8df56b0720476fe (diff)
downloadports-747b317dc1c54bfff398f1c54df46c9fa76e7d3b.tar.gz
ports-747b317dc1c54bfff398f1c54df46c9fa76e7d3b.zip
Add py-pydot 0.9.9, a Python interface to the Graphviz Dot language.
PR: ports/71759 Submitted by: Stefan Walter <sw@gegenunendlich.de>
Notes
Notes: svn path=/head/; revision=124008
Diffstat (limited to 'graphics/py-pydot')
-rw-r--r--graphics/py-pydot/Makefile31
-rw-r--r--graphics/py-pydot/distinfo2
-rw-r--r--graphics/py-pydot/pkg-descr7
3 files changed, 40 insertions, 0 deletions
diff --git a/graphics/py-pydot/Makefile b/graphics/py-pydot/Makefile
new file mode 100644
index 000000000000..49f83eccc93f
--- /dev/null
+++ b/graphics/py-pydot/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pydot
+# Date created: 15 Sep 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pydot
+PORTVERSION= 0.9.9
+CATEGORIES= graphics python
+MASTER_SITES= http://dkbza.org/data/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= A Python interface to the Graphviz Dot language
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing \
+ dot:${PORTSDIR}/graphics/graphviz
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/dot_parser.py \
+ %%PYTHON_SITELIBDIR%%/dot_parser.pyc \
+ %%PYTHON_SITELIBDIR%%/dot_parser.pyo \
+ %%PYTHON_SITELIBDIR%%/pydot.py \
+ %%PYTHON_SITELIBDIR%%/pydot.pyc \
+ %%PYTHON_SITELIBDIR%%/pydot.pyo
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pydot/distinfo b/graphics/py-pydot/distinfo
new file mode 100644
index 000000000000..09c57eedb9f3
--- /dev/null
+++ b/graphics/py-pydot/distinfo
@@ -0,0 +1,2 @@
+MD5 (pydot-0.9.9.tar.gz) = 7023e7fad3baa464b1516135ff3bf390
+SIZE (pydot-0.9.9.tar.gz) = 14301
diff --git a/graphics/py-pydot/pkg-descr b/graphics/py-pydot/pkg-descr
new file mode 100644
index 000000000000..dcd13f76ed5e
--- /dev/null
+++ b/graphics/py-pydot/pkg-descr
@@ -0,0 +1,7 @@
+An interface for creating both directed and non directed graphs from
+Python. Currently all attributes implemented in the Dot language are
+supported (up to Graphviz 1.10). Output can be inlined in Postscript
+into interactive scientific environments like TeXmacs, or output in any
+of the format's supported by the Graphviz tools dot, neato, twopi.
+
+WWW: http://dkbza.org/pydot.html