aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pygraph
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-19 14:33:02 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-19 14:33:02 +0000
commitd4b6405f4053c8b4adb1f9516afe272c428ae29c (patch)
tree1fe5a180181d064bcf402673a7ef858f6ca88904 /graphics/py-pygraph
parentf02a61616c7be38d89aaa5f12f950fa7084b84dc (diff)
downloadports-d4b6405f4053c8b4adb1f9516afe272c428ae29c.tar.gz
ports-d4b6405f4053c8b4adb1f9516afe272c428ae29c.zip
Rename graphics/py-graph-core to graphics/py-pygraph. The new version works
correctly with python3. Use Github instead of PyPy for it has newer, unbreaking patches. Take maintainership. PR: 253691 Approved by: demon (maintainer)
Notes
Notes: svn path=/head/; revision=566069
Diffstat (limited to 'graphics/py-pygraph')
-rw-r--r--graphics/py-pygraph/Makefile22
-rw-r--r--graphics/py-pygraph/distinfo3
-rw-r--r--graphics/py-pygraph/pkg-descr8
3 files changed, 33 insertions, 0 deletions
diff --git a/graphics/py-pygraph/Makefile b/graphics/py-pygraph/Makefile
new file mode 100644
index 000000000000..bf6a57a41874
--- /dev/null
+++ b/graphics/py-pygraph/Makefile
@@ -0,0 +1,22 @@
+# Created by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+# $FreeBSD$
+
+PORTNAME= pygraph
+DISTVERSION= 0.2.1-4
+DISTVERSIONSUFFIX= -g037bb2f
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Graph manipulation library in pure Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_GITHUB= yes
+GH_ACCOUNT= jciskey
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pygraph/distinfo b/graphics/py-pygraph/distinfo
new file mode 100644
index 000000000000..ed3f0cf85f6a
--- /dev/null
+++ b/graphics/py-pygraph/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613740798
+SHA256 (jciskey-pygraph-0.2.1-4-g037bb2f_GH0.tar.gz) = 59cdaccb7294cf413ec8d13ddf74f55ff5ba8d1c830551af6018dbefe5ea608e
+SIZE (jciskey-pygraph-0.2.1-4-g037bb2f_GH0.tar.gz) = 31765
diff --git a/graphics/py-pygraph/pkg-descr b/graphics/py-pygraph/pkg-descr
new file mode 100644
index 000000000000..a9f843a6969d
--- /dev/null
+++ b/graphics/py-pygraph/pkg-descr
@@ -0,0 +1,8 @@
+Pygraph aims to be an easy-to-use and functional graph library that
+doesn't sacrifice advanced capabilities or usability in the process.
+
+By implementing the library in pure Python, it can be installed without
+any dependencies aside from the Python core, enabling maximum ease of
+use.
+
+WWW: https://github.com/jciskey/pygraph