aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pygraphviz
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-05-18 16:54:52 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-05-18 16:54:52 +0000
commitcc27f17799f6e6a799c8fc25fe82619d377b4eaa (patch)
tree6df9b406849bd2ac70068e761055c68400d3af87 /graphics/py-pygraphviz
parentf509104ec9c20b9fcf74c8a08863bfc011264b96 (diff)
downloadports-cc27f17799f6e6a799c8fc25fe82619d377b4eaa.tar.gz
ports-cc27f17799f6e6a799c8fc25fe82619d377b4eaa.zip
Create new port graphics/py3-pygraphviz:
- This is a variant of graphics/py-pygraphviz for Python 3.x. A separate port is needed until the ports tree gets VARIANTS support. The science/gramps port will soon be updated to a version which only supports python3, and it depends on py-pygraphviz with python3. To allow people to only use packages directly (and not ports), the package building infrastructure needs to build 2 packages: py-pygraphviz with python2 and py-pygraphviz with python3. Since the ports tree doesn't yet have VARIANTS support, this is not yet possible without making a separate py3-pygraphviz port. - Ensure graphics/py-pygraphviz does not clobber variables in slave port - While here, add LICENSE and LICENSE_FILE details to graphics/py-pygraphviz PR: 207039 Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D6281
Notes
Notes: svn path=/head/; revision=415457
Diffstat (limited to 'graphics/py-pygraphviz')
-rw-r--r--graphics/py-pygraphviz/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/py-pygraphviz/Makefile b/graphics/py-pygraphviz/Makefile
index 5fca6347fb60..823572b54418 100644
--- a/graphics/py-pygraphviz/Makefile
+++ b/graphics/py-pygraphviz/Makefile
@@ -10,11 +10,13 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
COMMENT= Python interface to GraphViz agraph
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcgraph.so:graphics/graphviz
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0.10.1:devel/py-nose
+TEST_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}nose>=0.10.1:devel/py-nose
-USES= pkgconfig python
+USES?= pkgconfig python
USE_PYTHON= autoplist concurrent distutils
PYDISTUTILS_BUILD_TARGET= build build_ext