aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyocr
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-28 18:36:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-28 18:36:16 +0000
commit64779785fea3554f15e52bcb24d85ed62a8cee74 (patch)
tree3313e3bf4763be000145bdec0c0e3690589fd7ea /graphics/py-pyocr
parente214c2b005ff591ab0748534927894bdec90d520 (diff)
downloadports-64779785fea3554f15e52bcb24d85ed62a8cee74.tar.gz
ports-64779785fea3554f15e52bcb24d85ed62a8cee74.zip
New port: graphics/py-pyocr: Python wrapper for OCR engines (Tesseract, Cuneiform, etc)
Notes
Notes: svn path=/head/; revision=475598
Diffstat (limited to 'graphics/py-pyocr')
-rw-r--r--graphics/py-pyocr/Makefile21
-rw-r--r--graphics/py-pyocr/distinfo3
-rw-r--r--graphics/py-pyocr/pkg-descr21
3 files changed, 45 insertions, 0 deletions
diff --git a/graphics/py-pyocr/Makefile b/graphics/py-pyocr/Makefile
new file mode 100644
index 000000000000..fa1d4b559e63
--- /dev/null
+++ b/graphics/py-pyocr/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyocr
+DISTVERSION= 0.5.2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python wrapper for OCR engines (Tesseract, Cuneiform, etc)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= gmake python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyocr/distinfo b/graphics/py-pyocr/distinfo
new file mode 100644
index 000000000000..5c8cd4631571
--- /dev/null
+++ b/graphics/py-pyocr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532763489
+SHA256 (pyocr-0.5.2.tar.gz) = bdc4d43bf9b63c2a9a4b2c9a1a623a0e63c8e6600eede5dbe866b31f3a5f2207
+SIZE (pyocr-0.5.2.tar.gz) = 17532
diff --git a/graphics/py-pyocr/pkg-descr b/graphics/py-pyocr/pkg-descr
new file mode 100644
index 000000000000..4e4706be9d70
--- /dev/null
+++ b/graphics/py-pyocr/pkg-descr
@@ -0,0 +1,21 @@
+PyOCR is an optical character recognition (OCR) tool wrapper for python. That
+is, it helps using various OCR tools from a Python program.
+
+It has been tested only on GNU/Linux systems. It should also work on similar
+systems (*BSD, etc). It may or may not work on Windows, MacOSX, etc.
+
+Supported OCR tools:
+* Libtesseract (Python bindings for the C API)
+* Tesseract (wrapper: fork + exec)
+* Cuneiform (wrapper: fork + exec)
+
+Features:
+* Supports all the image formats supported by Pillow, including jpeg, png, gif,
+ bmp, tiff and others
+* Various output types: text only, bounding boxes, etc.
+* Orientation detection (Tesseract and libtesseract only)
+* Can focus on digits only (Tesseract and libtesseract only)
+* Can save and reload boxes in hOCR format
+* PDF generation (libtesseract only)
+
+WWW: https://gitlab.gnome.org/World/OpenPaperwork/pyocr