aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyqrcode
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-06-03 03:13:13 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-06-03 03:13:13 +0000
commitb7787b29b8c0eca50dccd832f90229f1e5a31782 (patch)
tree42eb3faf6a7eea6e8ccd1ae92e09e2b7eaf41143 /graphics/py-pyqrcode
parenta69c2579c2e1d28e4472c1b3833ec6b548ad6930 (diff)
downloadports-b7787b29b8c0eca50dccd832f90229f1e5a31782.tar.gz
ports-b7787b29b8c0eca50dccd832f90229f1e5a31782.zip
[NEW] graphics/py-pyqrcode: Pure Python QR code generator with SVG, EPS, PNG and terminal output
The pyqrcode module is a QR code generator that is simple to use and written in pure python. The module can automates most of the building process for creating QR codes. Most codes can be created using only two lines of code! Unlike other generators, all of the helpers can be controlled manually. You are free to set any or all of the properties of your QR code. QR codes can be saved as SVG, XBM, EPS, PNG (by using the pypng module), or plain text. They can also be displayed directly in most terminal emulators and Tkinter. PIL is not used to render the image files. The pyqrcode module attempts to follow the QR code standard as closely as possible. The terminology and the encodings used in pyqrcode come directly from the standard. This module also follows the algorithm laid out in the standard. WWW: https://github.com/mnooner256/pyqrcode
Notes
Notes: svn path=/head/; revision=503343
Diffstat (limited to 'graphics/py-pyqrcode')
-rw-r--r--graphics/py-pyqrcode/Makefile35
-rw-r--r--graphics/py-pyqrcode/distinfo3
-rw-r--r--graphics/py-pyqrcode/pkg-descr17
3 files changed, 55 insertions, 0 deletions
diff --git a/graphics/py-pyqrcode/Makefile b/graphics/py-pyqrcode/Makefile
new file mode 100644
index 000000000000..70d53cc89424
--- /dev/null
+++ b/graphics/py-pyqrcode/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= pyqrcode
+PORTVERSION= 1.2.1
+CATEGORIES= graphics python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Pure Python QR code generator with SVG, EPS, PNG and terminal output
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/License
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes # LICENSE_FILE/tests not packaged in sdist
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= mnooner256
+GH_TAGNAME= 674a77b
+
+OPTIONS_DEFINE= PNG
+OPTIONS_DEFAULT= PNG
+
+PNG_DESC= PNG output rendering support
+
+PNG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}png>=0.0.13:graphics/py-png@${PY_FLAVOR}
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyqrcode/distinfo b/graphics/py-pyqrcode/distinfo
new file mode 100644
index 000000000000..deb214722df7
--- /dev/null
+++ b/graphics/py-pyqrcode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1559457299
+SHA256 (mnooner256-pyqrcode-1.2.1-674a77b_GH0.tar.gz) = ebc3b17c0b244042c06d9b4db5b04afef62cb071cefc225c7271e8e7c5ec6295
+SIZE (mnooner256-pyqrcode-1.2.1-674a77b_GH0.tar.gz) = 63345
diff --git a/graphics/py-pyqrcode/pkg-descr b/graphics/py-pyqrcode/pkg-descr
new file mode 100644
index 000000000000..61b45ec6622a
--- /dev/null
+++ b/graphics/py-pyqrcode/pkg-descr
@@ -0,0 +1,17 @@
+The pyqrcode module is a QR code generator that is simple to use and written
+in pure python. The module can automates most of the building process for
+creating QR codes. Most codes can be created using only two lines of code!
+
+Unlike other generators, all of the helpers can be controlled manually. You
+are free to set any or all of the properties of your QR code.
+
+QR codes can be saved as SVG, XBM, EPS, PNG (by using the pypng module), or
+plain text. They can also be displayed directly in most terminal emulators
+and Tkinter. PIL is not used to render the image files.
+
+The pyqrcode module attempts to follow the QR code standard as closely as
+possible. The terminology and the encodings used in pyqrcode come directly
+from the standard. This module also follows the algorithm laid out in the
+standard.
+
+WWW: https://github.com/mnooner256/pyqrcode