aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-traitsui
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-08-27 20:07:40 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-08-27 20:07:40 +0000
commit2197448e2cebb87dca9ea937b54bebae1da2573f (patch)
treed8635ab3a38cc9c78d3d171d75becf5405fdca4d /graphics/py-traitsui
parente66d1fcd28b32b467bfe95db07f25083e43a800b (diff)
downloadports-2197448e2cebb87dca9ea937b54bebae1da2573f.tar.gz
ports-2197448e2cebb87dca9ea937b54bebae1da2573f.zip
graphics/py-traitsui: Update to 6.1.2
* Enable build for all Python versions as the support for Python 3 has been added since the 5.0.0 release. * Introduce new default option QT5 [1] to let the port make use of the Qt5 toolkit. (Support for the wxPython toolkit is also available but was left out intentionally because it isn't available for Python 3, yet.) * Also add a "do-test" target to make future QA easier while I'm here. Changelog since 6.0.0: https://github.com/enthought/traitsui/blob/6.1.2/CHANGES.txt PR: 238469 Submitted by: vladimir.chukharev@gmail.com (maintainer) Reviewed by: koobs (Python) Approved by: vladimir.chukharev@gmail.com (maintainer) [1] Differential Revision: https://reviews.freebsd.org/D21229
Notes
Notes: svn path=/head/; revision=510023
Diffstat (limited to 'graphics/py-traitsui')
-rw-r--r--graphics/py-traitsui/Makefile42
-rw-r--r--graphics/py-traitsui/distinfo6
2 files changed, 42 insertions, 6 deletions
diff --git a/graphics/py-traitsui/Makefile b/graphics/py-traitsui/Makefile
index c14ac8990848..bcc952437e31 100644
--- a/graphics/py-traitsui/Makefile
+++ b/graphics/py-traitsui/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= traitsui
-PORTVERSION= 6.0.0
+PORTVERSION= 6.1.2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,10 +17,46 @@ LICENSE_FILE_LGPL21= ${WRKSRC}/image_LICENSE_Nuvola.txt
LICENSE_FILE_EPL= ${WRKSRC}/image_LICENSE_Eclipse.txt
# See ${WRKSRC}/image_LICENSE.txt for per file license information
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apptools>=4.3.0:devel/py-apptools@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traits>0:devel/py-traits@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyface>=6.0.0:devel/py-pyface@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+# The requirements are defined in traitsui/__init__.py
-USES= python:2.7
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traits>0:devel/py-traits@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${PY_FLAVOR}
+py27_TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+# Those requirements (except for pip + coverage) were extracted from etstool.py
+
+USES= python
USE_PYTHON= autoplist distutils
+
NO_ARCH= yes
+# Support for the wxPython toolkit is also available, but only for Python 2.
+# Python 3 needs wxPython 4 which isn't ported, yet. So we use only Qt5 for a
+# while to make the port useful for Python 2 and 3.
+OPTIONS_DEFINE= QT5
+OPTIONS_DEFAULT=QT5
+
+QT5_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments@${PY_FLAVOR}
+QT5_USES= pyqt:5
+QT5_USE= PYQT=core_run,gui_run,printsupport_run,svg_run,widgets_run
+
+# These tests were extracted from etstool.py and adapted to the ports test framework
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v traitsui.tests
+
+# The test "test_wrap_text_narrow_short" fails at the moment and is going to be
+# fixed with the next release.
+# See also: https://github.com/enthought/traitsui/issues/643
+#
+# Note: The occurences of "qt4" aren't typos
+do-test-QT5-on:
+ @cd ${WRKSRC} && ${SETENV} ETS_TOOLKIT=qt4 QT_API=pyqt5 \
+ ${PYTHON_CMD} -m nose -v -e 'test_wrap_text_narrow_short' traitsui.qt4.tests
+
.include <bsd.port.mk>
diff --git a/graphics/py-traitsui/distinfo b/graphics/py-traitsui/distinfo
index 56613c1b9847..21e99f9dfd8d 100644
--- a/graphics/py-traitsui/distinfo
+++ b/graphics/py-traitsui/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1525439408
-SHA256 (traitsui-6.0.0.tar.gz) = a75f159f001b71213e17b373461d8df619cd2ae30222a3a78c5e61d4a87dfdea
-SIZE (traitsui-6.0.0.tar.gz) = 5063415
+TIMESTAMP = 1565984705
+SHA256 (traitsui-6.1.2.tar.gz) = 698dd44d6ff6a50502f6ef0ffe545c233f2772e5c37127667302b8c845be9551
+SIZE (traitsui-6.1.2.tar.gz) = 5125470