aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-zbar-py
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-07-18 07:31:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-07-18 07:31:28 +0000
commitd59e12e9b4ca08facc7fcf0c539e38513815d7b9 (patch)
tree7428ddd743884c9129dc98026c8f3bc629be93f7 /graphics/py-zbar-py
parent82a90f9691872767aa2e2f6d02edd59405539d42 (diff)
downloadports-d59e12e9b4ca08facc7fcf0c539e38513815d7b9.tar.gz
ports-d59e12e9b4ca08facc7fcf0c539e38513815d7b9.zip
zbar-py is a module that provides an interface to the zbar bar-code reading
library, which can read most barcode formats as well as QR codes. Input images must be 2D numpy arrays of type uint8 (i.e. 2D greyscale images). WWW: https://pypi.org/project/zbar-py/
Notes
Notes: svn path=/head/; revision=542478
Diffstat (limited to 'graphics/py-zbar-py')
-rw-r--r--graphics/py-zbar-py/Makefile25
-rw-r--r--graphics/py-zbar-py/distinfo3
-rw-r--r--graphics/py-zbar-py/pkg-descr5
3 files changed, 33 insertions, 0 deletions
diff --git a/graphics/py-zbar-py/Makefile b/graphics/py-zbar-py/Makefile
new file mode 100644
index 000000000000..f50b06907db4
--- /dev/null
+++ b/graphics/py-zbar-py/Makefile
@@ -0,0 +1,25 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= zbar-py
+PORTVERSION= 1.0.4
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Interface to the zbar bar-code reading library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libzbar.so:graphics/zbar
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR}
+
+USES= iconv:wchar_t python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/zbar/_zbar.so
+
+.include <bsd.port.mk>
diff --git a/graphics/py-zbar-py/distinfo b/graphics/py-zbar-py/distinfo
new file mode 100644
index 000000000000..8ab657ec95cd
--- /dev/null
+++ b/graphics/py-zbar-py/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1594988085
+SHA256 (zbar-py-1.0.4.tar.gz) = 8f90fa36480f50109a8555a3e4debed69f70d8085545fd413190ae21a1455466
+SIZE (zbar-py-1.0.4.tar.gz) = 543874
diff --git a/graphics/py-zbar-py/pkg-descr b/graphics/py-zbar-py/pkg-descr
new file mode 100644
index 000000000000..3aca668a4786
--- /dev/null
+++ b/graphics/py-zbar-py/pkg-descr
@@ -0,0 +1,5 @@
+zbar-py is a module that provides an interface to the zbar bar-code reading
+library, which can read most barcode formats as well as QR codes. Input images
+must be 2D numpy arrays of type uint8 (i.e. 2D greyscale images).
+
+WWW: https://pypi.org/project/zbar-py/