aboutsummaryrefslogtreecommitdiff
path: root/graphics/q-graph
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-09 00:55:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-09 00:55:57 +0000
commit32f9d63c3dc2d6bb5945408fabcba0a103bddc0a (patch)
tree0b7ef9e05796762b7f30d4497e68153fe0520e2e /graphics/q-graph
parentf2fcb94f172ad16be6163c675a80b15103054a94 (diff)
downloadports-32f9d63c3dc2d6bb5945408fabcba0a103bddc0a.tar.gz
ports-32f9d63c3dc2d6bb5945408fabcba0a103bddc0a.zip
Notes
Diffstat (limited to 'graphics/q-graph')
-rw-r--r--graphics/q-graph/Makefile32
-rw-r--r--graphics/q-graph/distinfo1
-rw-r--r--graphics/q-graph/pkg-descr13
-rw-r--r--graphics/q-graph/pkg-plist10
4 files changed, 56 insertions, 0 deletions
diff --git a/graphics/q-graph/Makefile b/graphics/q-graph/Makefile
new file mode 100644
index 000000000000..63b94c7bb326
--- /dev/null
+++ b/graphics/q-graph/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: q-graph
+# Date created: 14 August 2003
+# Whom: ag@muwiinfa.geschichte.uni-mainz.de Albert Graef
+#
+# $FreeBSD$
+#
+
+PORTNAME= graph
+PORTVERSION= 1.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= q-lang
+PKGNAMEPREFIX= q-
+
+MAINTAINER= ag@muwiinfa.geschichte.uni-mainz.de
+COMMENT= Q-Graph -- graph library and editor for the Q language
+
+RUN_DEPENDS= ${LOCALBASE}/bin/q:${PORTSDIR}/lang/q
+
+USE_REINPLACE= yes
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+
+DATADIR= ${PREFIX}/share/q
+EXAMPLESDIR= ${PREFIX}/share/examples/q/graph
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
+ ${GREP} -l "^examplesdir" | ${XARGS} ${REINPLACE_CMD} -e \
+ "s;[(]pkgdatadir[)]/examples;(datadir)/examples/q;"
+
+.include <bsd.port.mk>
diff --git a/graphics/q-graph/distinfo b/graphics/q-graph/distinfo
new file mode 100644
index 000000000000..a9c80bda3b8c
--- /dev/null
+++ b/graphics/q-graph/distinfo
@@ -0,0 +1 @@
+MD5 (graph-1.2.tar.gz) = 18498370afdfd106e52a5987a8cc1768
diff --git a/graphics/q-graph/pkg-descr b/graphics/q-graph/pkg-descr
new file mode 100644
index 000000000000..c81ed0cf9f1b
--- /dev/null
+++ b/graphics/q-graph/pkg-descr
@@ -0,0 +1,13 @@
+This is Q-Graph, a graph library and editor for the Q programming language.
+The package contains:
+
+- graph.q: a graph data structure implemented as a kind of asymmetric
+ adjacency list dictionary, and a collection of the usual graph operations
+
+- graphed.q: a full-featured graph editor, allows you to create and edit your
+ input graphs with ease (requires Tcl/Tk)
+
+WWW: http://q-lang.sourceforge.net
+
+- Albert Graef
+ag@muwiinfa.geschichte.uni-mainz.de
diff --git a/graphics/q-graph/pkg-plist b/graphics/q-graph/pkg-plist
new file mode 100644
index 000000000000..9f603b62c0aa
--- /dev/null
+++ b/graphics/q-graph/pkg-plist
@@ -0,0 +1,10 @@
+bin/graphed
+bin/graphed2
+%%DATADIR%%/etc/README-Graph
+%%DATADIR%%/lib/graph.q
+%%DATADIR%%/lib/graphed.q
+%%DATADIR%%/lib/graphed.tcl
+%%EXAMPLESDIR%%/G
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/dijkstra.q
+@dirrm %%EXAMPLESDIR%%