aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-10-09 00:25:28 +0000
committerWen Heping <wen@FreeBSD.org>2009-10-09 00:25:28 +0000
commite8e6e5b1f7fae856902941b5373d565c2ca6a182 (patch)
treea029aee8fbcc67b204ef8a965e44ee87cdf43be9 /graphics/qgis/Makefile
parentf40fc37a9665c073b9f7abc9bf55fce3174d5423 (diff)
downloadports-e8e6e5b1f7fae856902941b5373d565c2ca6a182.tar.gz
ports-e8e6e5b1f7fae856902941b5373d565c2ca6a182.zip
Notes
Diffstat (limited to 'graphics/qgis/Makefile')
-rw-r--r--graphics/qgis/Makefile34
1 files changed, 29 insertions, 5 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index cbe55204270e..3b6d362f41d3 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qgis
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/qgis/src/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -20,22 +19,24 @@ LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
gsl.13:${PORTSDIR}/math/gsl \
gdal:${PORTSDIR}/graphics/gdal
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_PYTHON= yes
USE_BISON= build
USE_CMAKE= yes
USE_QT_VER= 4
USE_SQLITE= yes
CMAKE_USE_PTHREAD= yes
CMAKE_ENV+= QMAKESPEC=${QMAKESPEC}
-QT_COMPONENTS= gui svg xml network sql linguist_build \
+QT_COMPONENTS= gui svg xml network sql linguist \
qmake_build moc_build rcc_build uic_build
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-qtdir=${QTDIR}
USE_LDCONFIG= yes
OPTIONS= GRASS "Enable GRASS support" Off \
- POSTGIS "Enable PostGIS support" Off
+ POSTGIS "Enable PostGIS support" Off \
+ PYTHON "Enable Python support" On
.include <bsd.port.pre.mk>
@@ -61,4 +62,27 @@ CONFIGURE_ARGS+=--without-postgresql
PLIST_SUB+= PGSQL="@comment "
.endif
+.if defined(WITHOUT_PYTHON)
+PLIST_SUB+= QGIS_PYTHON="@comment "
+.else
+PLIST_SUB+= QGIS_PYTHON=""
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sip>=4.8.2:${PORTSDIR}/devel/py-sip \
+ ${PYTHON_PKGNAMEPREFIX}qt4-gui>=4.5.4:${PORTSDIR}/x11-toolkits/py-qt4-gui \
+ ${PYTHON_PKGNAMEPREFIX}qt4-network>=4.5.4:${PORTSDIR}/net/py-qt4-network \
+ ${PYTHON_PKGNAMEPREFIX}qt4-svg>=4.5.4:${PORTSDIR}/graphics/py-qt4-svg \
+ ${PYTHON_PKGNAMEPREFIX}qt4-xml>=4.5.4:${PORTSDIR}/textproc/py-qt4-xml \
+ ${PYTHON_PKGNAMEPREFIX}qt4-core>=4.5.4:${PORTSDIR}/devel/py-qt4-core
+.endif
+
+MAN1= qgis.1 qgis_help.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's# dl##g' \
+ ${WRKSRC}/src/core/CMakeLists.txt
+
+.if defined(WITHOUT_PYTHON)
+ ${REINPLACE_CMD} -e 's#WITH_BINDINGS TRUE#WITH_BINDINGS FALSE#g' \
+ ${WRKSRC}/CMakeLists.txt
+.endif
+
.include <bsd.port.post.mk>