aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-12-08 20:03:07 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-12-08 20:03:07 +0000
commit47b26d9293f196d71c39ba4d82df23d179884405 (patch)
tree3984ac0366432e29f9e1ac47cbac9b18032f7c04 /graphics/qgis
parent96fd51619a1ebc0b215ab75ccc37ce7ab300ed8b (diff)
downloadports-47b26d9293f196d71c39ba4d82df23d179884405.tar.gz
ports-47b26d9293f196d71c39ba4d82df23d179884405.zip
Update Qt/PySide2 to 5.15.2 / PyQt to 5.15.1 / SIP to 5.4.0
This commit combines several updates. - Update Qt to 5.12.2 - Update PyQt to 5.15.1 - Since PySide 5.15.1 is broken with Qt 5.15.2, so PySide and Shiboken are also updated to 5.15.2. - Update sip to 5.4.0 SIP is a collection of tools to create Python bindings for C and C++ libraries and used by PyQt and wxPython. There are some changes with sip5 [1]: - python 3.5+ is required - sip drops support of old deprecated methods as sipdistutils & cie. - this version breaks also PyQt5 extension ABI. SIP files will be installed in ${PYTHON_SITELIBDIR}/PyQt${_PYQT_VERSION}/bindings - some ports will use the new pyqtbuilder package with the pyproject.toml setup. Instead if the project have a setup.py, you should use sip-build to build it. - if a port needs sip, it should also needs pysip. BTW, py-qt5-core requires pysip, so that should be enough for PyQt packages. List of ports impacted by this change. Most of the patches have been integrated or are in the process of being integrated upstream: - devel/libsavitar - graphics/py-python-poppler-qt5 - net-im/scudcloud - net/libarcus - print/py-frescobaldi - science/py-veusz - graphics/qgis and graphics/qgis-ltr - deskutils/calibre A special note regarding calibre. New versions require sip>=5, we update it to the latest version (thanks to madpilot@) science/scidavis will remove the PyQt binding soon and there is no patch planned, so we remove the python option (ok makc@) While here, convert some ports to USE_PYQT (cad/cura, cad/uranium, devel/eric6, ...) Thanks to tcberner and adridg! [1] https://www.riverbankcomputing.com/static/Docs/sip/ PR: 250853 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=557300
Diffstat (limited to 'graphics/qgis')
-rw-r--r--graphics/qgis/Makefile11
-rw-r--r--graphics/qgis/files/patch-cmake_FindPyQt5.py11
-rw-r--r--graphics/qgis/files/patch-cmake_FindSIP.py9
3 files changed, 5 insertions, 26 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 82650b201952..a2538aaab8dd 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -7,6 +7,8 @@ DISTVERSION= 3_16_1
PORTREVISION= 1
CATEGORIES= graphics geography
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+
MAINTAINER= rhurlin@FreeBSD.org
COMMENT= Free and Open Source Geographic Information System
@@ -85,7 +87,6 @@ RUN_DEPENDS= astyle:devel/astyle \
${PYTHON_PKGNAMEPREFIX}pyproj>=2.1.3:graphics/py-pyproj@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyrsgis>=0.2.6:graphics/py-pyrsgis@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=2020.1:devel/py-pytz@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}qt5-quick>=5.13.1:x11-toolkits/py-qt5-quick@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.22.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-image>=0.14.3:graphics/py-scikit-image@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Shapely>=1.6.4:devel/py-shapely@${PY_FLAVOR} \
@@ -108,8 +109,9 @@ USE_QT= 3d buildtools_build core concurrent dbus declarative \
network printsupport qmake_build script serialport \
sql sql-pgsql sql-sqlite3 svg testlib uitools \
webengine widgets webkit xml
-USE_PYQT= core gui network qml quickwidgets qscintilla2 \
- sip sql svg webkit_run webkitwidgets_run xml
+USE_PYQT= core gui network qml quick quickwidgets qscintilla2 \
+ pysip sip sql svg webkit_run webkitwidgets_run xml
+
CONFLICTS_INSTALL= qgis-ltr
@@ -160,9 +162,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|"-mllvm -inline-threshold=128"|"-O1"|g' \
${WRKSRC}/src/core/CMakeLists.txt
.endif
- @${REINPLACE_CMD} -e 's|%%PYQT_SIPDIR%%|${PYQT_SIPDIR}|' \
- ${WRKSRC}/cmake/FindPyQt5.py \
- ${WRKSRC}/cmake/FindSIP.py
pre-configure:
${MKDIR} ${CONFIGURE_WRKSRC}/bin && ${LN} -s ${PYTHON_CMD} ${CONFIGURE_WRKSRC}/bin/python3
diff --git a/graphics/qgis/files/patch-cmake_FindPyQt5.py b/graphics/qgis/files/patch-cmake_FindPyQt5.py
deleted file mode 100644
index 265f439b546c..000000000000
--- a/graphics/qgis/files/patch-cmake_FindPyQt5.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/FindPyQt5.py.orig 2020-08-20 07:52:34 UTC
-+++ cmake/FindPyQt5.py
-@@ -61,7 +61,7 @@ else: # Code for SIP v5
- import shutil
- cfg = {
- 'pyqt_mod_dir': os.path.dirname(PyQt5.__file__),
-- 'pyqt_sip_dir': os.path.join(get_python_lib(plat_specific=1), "PyQt5", "bindings"),
-+ 'pyqt_sip_dir': "%%PYQT_SIPDIR%%",
- 'pyqt_bin_dir': os.path.dirname(shutil.which("pyuic5")),
- }
-
diff --git a/graphics/qgis/files/patch-cmake_FindSIP.py b/graphics/qgis/files/patch-cmake_FindSIP.py
deleted file mode 100644
index 9458efe06dee..000000000000
--- a/graphics/qgis/files/patch-cmake_FindSIP.py
+++ /dev/null
@@ -1,9 +0,0 @@
---- cmake/FindSIP.py.orig 2020-08-20 07:34:51 UTC
-+++ cmake/FindSIP.py
-@@ -56,5 +56,5 @@ else: # Code for SIP v5
- print("sip_bin:%s" % shutil.which("sip5"))
-
- from distutils.sysconfig import get_python_lib
-- python_modules_dir = get_python_lib(plat_specific=1)
-+ python_modules_dir = "%%PYQT_SIPDIR%%"
- print("default_sip_dir:%s" % python_modules_dir)