aboutsummaryrefslogtreecommitdiff
path: root/graphics/qr-code-generator
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-01-21 22:55:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-01-21 22:55:09 +0000
commitc268a8a47f102e431fb79db5aec8c7ea6c179a40 (patch)
treea6d26ab1ff1a417871916aa8adb234f8f0f41ebe /graphics/qr-code-generator
parent2b370215da6ef0827affe26823d3598d15f5b355 (diff)
downloadports-c268a8a47f102e431fb79db5aec8c7ea6c179a40.tar.gz
ports-c268a8a47f102e431fb79db5aec8c7ea6c179a40.zip
Fix build on GCC-based systems:
BitBuffer.cpp:30: error: invalid use of incomplete type 'struct qrcodegen::BitBuffer' USE_CSTD=c99 was not sufficient: qrcodegen.c:149: error: 'for' loop initial declaration used outside C99 mode Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=523751
Diffstat (limited to 'graphics/qr-code-generator')
-rw-r--r--graphics/qr-code-generator/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/qr-code-generator/Makefile b/graphics/qr-code-generator/Makefile
index 03dbb1e648a5..b8634e531256 100644
--- a/graphics/qr-code-generator/Makefile
+++ b/graphics/qr-code-generator/Makefile
@@ -10,7 +10,7 @@ COMMENT= High-quality QR Code generator library
LICENSE= MIT
-USES= gmake
+USES= compiler:c++11-lang gmake
USE_LDCONFIG= yes