aboutsummaryrefslogtreecommitdiff
path: root/graphics/qtqr/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-07-18 07:32:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-07-18 07:32:22 +0000
commite3ffb1d2cb23b2c6a28f47dff10646eb34e54117 (patch)
tree35b0be6ba90c8ffc81de50eab8029e168df60b5c /graphics/qtqr/Makefile
parentd59e12e9b4ca08facc7fcf0c539e38513815d7b9 (diff)
downloadports-e3ffb1d2cb23b2c6a28f47dff10646eb34e54117.tar.gz
ports-e3ffb1d2cb23b2c6a28f47dff10646eb34e54117.zip
Notes
Diffstat (limited to 'graphics/qtqr/Makefile')
-rw-r--r--graphics/qtqr/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/qtqr/Makefile b/graphics/qtqr/Makefile
new file mode 100644
index 000000000000..bdbf1e2d5eb9
--- /dev/null
+++ b/graphics/qtqr/Makefile
@@ -0,0 +1,39 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= qtqr
+DISTVERSION= 2.0.bzr39
+CATEGORIES= graphics python
+MASTER_SITES= LOCAL/ehaupt
+DISTNAME= qr-tools-${DISTVERSION}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= GUI that makes easy creating and decoding the QR Codes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zbar-py>=1.0.4:graphics/py-zbar-py@${PY_FLAVOR}
+
+USES= desktop-file-utils pyqt:5 python:3.6+ shebangfix
+USE_PYQT= core_run gui_run network_run widgets_run
+USE_PYTHON= autoplist distutils
+
+SHEBANG_FILES= qtqr.py
+
+NO_BUILD= yes
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/qtqr.py ${STAGEDIR}${PREFIX}/bin/qtqr
+ ${INSTALL_DATA} ${WRKSRC}/icon.png ${STAGEDIR}${PREFIX}/share/pixmaps/qtqr.png
+ ${INSTALL_DATA} ${WRKSRC}/qtqr.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/qt5/translations
+ ${INSTALL_DATA} ${WRKSRC}/*.qm ${STAGEDIR}${PREFIX}/share/qt5/translations
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>