aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat-gui
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/quat-gui
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/quat-gui')
-rw-r--r--graphics/quat-gui/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 4348856c6975..8cfdfe8407b4 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quat
PORTVERSION= 1.20
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
PKGNAMESUFFIX= -gui
@@ -16,12 +16,13 @@ DISTNAME= quat-${PORTVERSION:S/.p/pre/}
MAINTAINER= dyeske@gmail.com
COMMENT= A Three-dimensional fractal creator (X11 GUI)
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- glut.4:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+USE_XORG= xext
+USE_GL= gl glut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -L${X11BASE}/lib" \
- LIBS="-lXext -lGL" FLUID="${X11BASE}/bin/fluid}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ LIBS="-lXext -lGL" FLUID="${LOCALBASE}/bin/fluid"
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math