aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-21 05:51:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-21 05:51:07 +0000
commit7ff7cba6f27fc85562d857d363b8cf33a4580f80 (patch)
tree0d050e3955b798aecf364c849670ce76a56fbb6f /graphics/quat
parent37fb7142814828d945d9404e7a1ff7e627cab898 (diff)
downloadports-7ff7cba6f27fc85562d857d363b8cf33a4580f80.tar.gz
ports-7ff7cba6f27fc85562d857d363b8cf33a4580f80.zip
- Update MASTER_SITES
- Add LICENSE - Add MAKE_JOBS_SAFE - Support PLIST_FILES - Trim Header PR: 178593 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=318643
Diffstat (limited to 'graphics/quat')
-rw-r--r--graphics/quat/Makefile48
-rw-r--r--graphics/quat/pkg-plist27
2 files changed, 27 insertions, 48 deletions
diff --git a/graphics/quat/Makefile b/graphics/quat/Makefile
index 696ad47f7a4e..7cbed1695d71 100644
--- a/graphics/quat/Makefile
+++ b/graphics/quat/Makefile
@@ -1,46 +1,52 @@
-# New ports collection makefile for: quat
-# Date created: 26 Aug 2002
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= quat
PORTVERSION= 1.20
CATEGORIES= graphics
-MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
+#MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
+MASTER_SITES= http://www.sourcefiles.org/Graphics/Fractals/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Three-dimensional fractal creator (command line only)
+COMMENT= Three-dimensional fractal creator (command line only)
+
+LICENSE= GPLv2 # (or later)
+
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gui \
--datadir=${PREFIX}/share/doc
+MAKE_JOBS_SAFE= yes
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -ffast-math
-.endif
+PORTDOCS= *
+PLIST_FILES= bin/quat-txt
+
+.include <bsd.port.options.mk>
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} "You can enable additional compilation optimizations"
- @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+CFLAGS+= -O3 -ffast-math
.endif
post-patch:
- @${REINPLACE_CMD} -E -e 's,-(march=pentium|O3|ffast-math),,g' \
+ @${REINPLACE_CMD} -E -e \
+ 's,-(march=pentium|O3|ffast-math),,g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -E -e 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
+ @${REINPLACE_CMD} -E -e \
+ 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
${WRKSRC}/kernel/Makefile.in
# disable data file installation since distfile does not do
# The Right Thing(TM)
@${REINPLACE_CMD} -E -e \
- 's|^(install-data-am:).*$$|\1|' \
- ${WRKSRC}/Makefile.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -E -e \
- 's|^(SUBDIRS.*)doc|\1|' \
+ 's|^(install-data-am:).*$$|\1| ; \
+ s|^(SUBDIRS.*)doc|\1|' \
${WRKSRC}/Makefile.in
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endif
.include <bsd.port.mk>
diff --git a/graphics/quat/pkg-plist b/graphics/quat/pkg-plist
index 49b1a74d4ce5..e69de29bb2d1 100644
--- a/graphics/quat/pkg-plist
+++ b/graphics/quat/pkg-plist
@@ -1,27 +0,0 @@
-bin/quat-txt
-%%PORTDOCS%%share/doc/quat/Dendr_st.jpg
-%%PORTDOCS%%share/doc/quat/ce.png
-%%PORTDOCS%%share/doc/quat/chart_de.png
-%%PORTDOCS%%share/doc/quat/chart_us.png
-%%PORTDOCS%%share/doc/quat/ex_1.jpg
-%%PORTDOCS%%share/doc/quat/ex_2.jpg
-%%PORTDOCS%%share/doc/quat/ex_3.jpg
-%%PORTDOCS%%share/doc/quat/gpl.html
-%%PORTDOCS%%share/doc/quat/ie.png
-%%PORTDOCS%%share/doc/quat/oe.png
-%%PORTDOCS%%share/doc/quat/ote.png
-%%PORTDOCS%%share/doc/quat/quat-de-1.html
-%%PORTDOCS%%share/doc/quat/quat-de-2.html
-%%PORTDOCS%%share/doc/quat/quat-de-3.html
-%%PORTDOCS%%share/doc/quat/quat-de-4.html
-%%PORTDOCS%%share/doc/quat/quat-de-5.html
-%%PORTDOCS%%share/doc/quat/quat-de.html
-%%PORTDOCS%%share/doc/quat/quat-us-1.html
-%%PORTDOCS%%share/doc/quat/quat-us-2.html
-%%PORTDOCS%%share/doc/quat/quat-us-3.html
-%%PORTDOCS%%share/doc/quat/quat-us-4.html
-%%PORTDOCS%%share/doc/quat/quat-us-5.html
-%%PORTDOCS%%share/doc/quat/quat-us.html
-%%PORTDOCS%%share/doc/quat/quat.png
-%%PORTDOCS%%share/doc/quat/ve.png
-%%PORTDOCS%%@dirrm share/doc/quat