aboutsummaryrefslogtreecommitdiff
path: root/graphics/qxv
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-08-29 01:24:04 +0000
committerCy Schubert <cy@FreeBSD.org>2012-08-29 01:24:04 +0000
commit3c2a77dab90e9549ea1646f51e5e3d5464ecbf89 (patch)
treef7cb12ef3e0ba1a55f17dc44710263e113a0bc3a /graphics/qxv
parentd0f2e58a1b3f3d4f7dabe83f5cf1be3471877202 (diff)
downloadports-3c2a77dab90e9549ea1646f51e5e3d5464ecbf89.tar.gz
ports-3c2a77dab90e9549ea1646f51e5e3d5464ecbf89.zip
Notes
Diffstat (limited to 'graphics/qxv')
-rw-r--r--graphics/qxv/Makefile46
-rw-r--r--graphics/qxv/distinfo2
-rw-r--r--graphics/qxv/pkg-descr7
3 files changed, 55 insertions, 0 deletions
diff --git a/graphics/qxv/Makefile b/graphics/qxv/Makefile
new file mode 100644
index 000000000000..1694fce60fa0
--- /dev/null
+++ b/graphics/qxv/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: qxv
+# Date created: 28 August 2012
+# Whom: cy
+#
+# $FreeBSD$
+#
+
+PORTNAME= qxv
+PORTVERSION= 0.2
+CATEGORIES+= graphics
+MASTER_SITES= http://labs.freehackers.org/attachments/download/422/
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= A QT4 program that displays images of various formats
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
+ glib-2.0.0:${PORTSDIR}/devel/glib20 \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ iconv.3:${PORTSDIR}/converters/iconv \
+ icui18n.48:${PORTSDIR}/devel/icu \
+ intl.9:${PORTSDIR}/devel/gettext \
+ pcre.1:${PORTSDIR}/devel/pcre \
+ pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs \
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ xcb.2:${PORTSDIR}/x11/xcb
+
+USE_BZIP2= yes
+USE_XORG= sm xrender xext x11 xau xdmcp ice
+USE_QT4= corelib gui qmake_build
+HAS_CONFIGURE= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${INSTALL_PROGRAM} ${PORTNAME} ${LOCALBASE}/bin/
+
+.include <bsd.port.mk>
diff --git a/graphics/qxv/distinfo b/graphics/qxv/distinfo
new file mode 100644
index 000000000000..98bfc9090151
--- /dev/null
+++ b/graphics/qxv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qxv-0.2.tar.bz2) = 67f8880ce35ef3220a09cecd6c88a09a60dab1f13c7511653ecf818b7111947a
+SIZE (qxv-0.2.tar.bz2) = 16641
diff --git a/graphics/qxv/pkg-descr b/graphics/qxv/pkg-descr
new file mode 100644
index 000000000000..c6d9bbf0f8e4
--- /dev/null
+++ b/graphics/qxv/pkg-descr
@@ -0,0 +1,7 @@
+qxv is an image viewer whose interface is key-to-key compatible with the
+classic xv program. It is meant to replace xv, which is old, unmaintained,
+not Free Software, and therefore not shipped with most software
+distributions anymore.
+
+
+WWW: http://freecode.com/projects/qxv