aboutsummaryrefslogtreecommitdiff
path: root/graphics/radius-engine/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-08 16:33:00 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-08 16:33:00 +0000
commite9c4b141b741de03c592265ef9c39e766ad93e4f (patch)
treefab71b0bd69e4cef4efe4f5e822b6eae9c19f414 /graphics/radius-engine/Makefile
parent9179d9dd03d086e69051c319b5d5ba6f789bcdd4 (diff)
downloadports-e9c4b141b741de03c592265ef9c39e766ad93e4f.tar.gz
ports-e9c4b141b741de03c592265ef9c39e766ad93e4f.zip
Notes
Diffstat (limited to 'graphics/radius-engine/Makefile')
-rw-r--r--graphics/radius-engine/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/radius-engine/Makefile b/graphics/radius-engine/Makefile
index dc2651dacc3a..c0c1e3dc3615 100644
--- a/graphics/radius-engine/Makefile
+++ b/graphics/radius-engine/Makefile
@@ -6,14 +6,14 @@ PORTVERSION= 1.1
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME}/
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Lua script-based 2D engine built on top of OpenGL and SDL
LICENSE= MIT
-LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
- png15:${PORTSDIR}/graphics/png \
- physfs.1:${PORTSDIR}/devel/physfs
+LIB_DEPENDS= liblua-5.1.so:${PORTSDIR}/lang/lua \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libphysfs.so.1:${PORTSDIR}/devel/physfs
USES= pathfix pkgconfig
USE_SDL= sdl sound
@@ -25,9 +25,7 @@ CFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= include/radius.h \
lib/libradius-engine.a \
libdata/pkgconfig/radius-engine.pc
-PLIST_DIRSTRY= libdata/pkgconfig
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|lua5.1|lua-5.1|g' \
${WRKSRC}/acinclude.m4 ${WRKSRC}/configure