aboutsummaryrefslogtreecommitdiff
path: root/graphics/radius-engine
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-24 13:56:07 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-24 13:56:07 +0000
commit47b48988aa7fe1c1c0f221ce9cb124af07f62a16 (patch)
treed6f21bc4ccbce817bf262af457ee2e609dd27e6f /graphics/radius-engine
parentd2e582ca752c09561be9a826b02a786854189c7f (diff)
downloadports-47b48988aa7fe1c1c0f221ce9cb124af07f62a16.tar.gz
ports-47b48988aa7fe1c1c0f221ce9cb124af07f62a16.zip
graphics/radius-engine: minor fixes
- Use pathfix instead of manual replace - Trim Makefile header PR: ports/179894 Submitted by: nemysis <nemysis@gmx.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=321683
Diffstat (limited to 'graphics/radius-engine')
-rw-r--r--graphics/radius-engine/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/graphics/radius-engine/Makefile b/graphics/radius-engine/Makefile
index a4e4e412daf1..1a282b79000a 100644
--- a/graphics/radius-engine/Makefile
+++ b/graphics/radius-engine/Makefile
@@ -1,9 +1,5 @@
-# New Ports collection makefile for: Radius Engine
-# Date created: 2012-05-17
-# Whom: nemysis@gmx.ch
-#
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
-#
PORTNAME= radius-engine
PORTVERSION= 1.1
@@ -19,11 +15,12 @@ LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
png15:${PORTSDIR}/graphics/png \
physfs.1:${PORTSDIR}/devel/physfs
+USES= pathfix
+USE_SDL= sdl sound
+USE_GL= glu
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CFLAGS+= -I${LOCALBASE}/include
-USE_SDL= sdl sound
-USE_GL= glu
MAKE_JOBS_SAFE= yes
PLIST_FILES= include/radius.h \
@@ -34,6 +31,5 @@ PLIST_DIRSTRY= libdata/pkgconfig
post-patch:
@${REINPLACE_CMD} -e 's|lua5.1|lua-5.1|g' \
${WRKSRC}/acinclude.m4 ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|(pkgconfigdir)|{PREFIX}/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>