aboutsummaryrefslogtreecommitdiff
path: root/graphics/rapid-photo-downloader
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-03 07:14:53 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-03 07:14:53 +0000
commitcd3a4894b7d90c6eb38e4bd560a1414a74237a0c (patch)
tree22c9b64058c30981d2a5841c3c16a8f51ee91a4a /graphics/rapid-photo-downloader
parent8503b1b64df1206fef3fe229ca89a0017ef9542d (diff)
downloadports-cd3a4894b7d90c6eb38e4bd560a1414a74237a0c.tar.gz
ports-cd3a4894b7d90c6eb38e4bd560a1414a74237a0c.zip
Update to 0.9.23
PR: 243472 Submitted by: m.ne@gmx.net (maintainer) Approved by: ehaupt (mentor) Changelog: https://launchpadlibrarian.net/474969649/CHANGES.rst
Notes
Notes: svn path=/head/; revision=533752
Diffstat (limited to 'graphics/rapid-photo-downloader')
-rw-r--r--graphics/rapid-photo-downloader/Makefile8
-rw-r--r--graphics/rapid-photo-downloader/distinfo6
-rw-r--r--graphics/rapid-photo-downloader/files/patch-raphodo_rapid.py26
-rw-r--r--graphics/rapid-photo-downloader/files/patch-raphodo_storage.py14
-rw-r--r--graphics/rapid-photo-downloader/files/patch-raphodo_utilities.py10
-rw-r--r--graphics/rapid-photo-downloader/files/patch-setup.py10
6 files changed, 44 insertions, 30 deletions
diff --git a/graphics/rapid-photo-downloader/Makefile b/graphics/rapid-photo-downloader/Makefile
index 88964d80f061..b80690340b2c 100644
--- a/graphics/rapid-photo-downloader/Makefile
+++ b/graphics/rapid-photo-downloader/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= rapid-photo-downloader
-DISTVERSION= 0.9.17
-PORTREVISION= 2
+DISTVERSION= 0.9.23
CATEGORIES= graphics
MASTER_SITES= https://launchpad.net/rapid/pyqt/${PORTVERSION}/+download/
@@ -15,6 +14,7 @@ BUILD_DEPENDS= intltool-update:textproc/intltool
LIB_DEPENDS= libgexiv2.so:graphics/gexiv2 \
libgudev-1.0.so:devel/libgudev
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>0:devel/py-arrow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Babel>0:devel/py-babel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}colour>0:graphics/py-colour@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>2.2:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}easygui>=0:x11-toolkits/py-easygui@${PY_FLAVOR} \
@@ -51,4 +51,8 @@ PROGRESS_DESC= shows a progress bar on the command line
COLOUR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorlog>0:devel/py-colorlog@${PY_FLAVOR}
PROGRESS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyprind>=1.4.0:misc/py-pyprind@${PY_FLAVOR}
+post-patch:
+ @${REINPLACE_CMD} -e 's|'share/man/man1'|'man/man1'|' \
+ ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/graphics/rapid-photo-downloader/distinfo b/graphics/rapid-photo-downloader/distinfo
index 6258f9cb7a78..81044972a21b 100644
--- a/graphics/rapid-photo-downloader/distinfo
+++ b/graphics/rapid-photo-downloader/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1568565754
-SHA256 (rapid-photo-downloader-0.9.17.tar.gz) = 26dbce5d2e775af39ce8f17224a862ed71a86a47768a7ebb04193d96535c7883
-SIZE (rapid-photo-downloader-0.9.17.tar.gz) = 6877573
+TIMESTAMP = 1587355599
+SHA256 (rapid-photo-downloader-0.9.23.tar.gz) = 2bfe30e237803870486ee5e79e482529da4c592930e48d1ba20c03f36f6719f4
+SIZE (rapid-photo-downloader-0.9.23.tar.gz) = 8101336
diff --git a/graphics/rapid-photo-downloader/files/patch-raphodo_rapid.py b/graphics/rapid-photo-downloader/files/patch-raphodo_rapid.py
index 26fc07391c24..081a6cc81289 100644
--- a/graphics/rapid-photo-downloader/files/patch-raphodo_rapid.py
+++ b/graphics/rapid-photo-downloader/files/patch-raphodo_rapid.py
@@ -1,6 +1,6 @@
---- raphodo/rapid.py.orig 2019-08-18 03:58:11 UTC
+--- raphodo/rapid.py.orig 2020-04-17 01:22:23 UTC
+++ raphodo/rapid.py
-@@ -98,7 +98,7 @@ from PyQt5.QtNetwork import QLocalSocket, QLocalServer
+@@ -96,7 +96,7 @@ from PyQt5.QtNetwork import QLocalSocket, QLocalServer
import sip
from raphodo.storage import (
@@ -9,7 +9,7 @@
has_one_or_more_folders, mountPaths, get_desktop_environment, get_desktop,
gvfs_controls_mounts, get_default_file_manager, validate_download_folder,
validate_source_folder, get_fdo_cache_thumb_base_directory, WatchDownloadDirs, get_media_dir,
-@@ -584,12 +584,12 @@ class RapidWindow(QMainWindow):
+@@ -609,12 +609,12 @@ class RapidWindow(QMainWindow):
self.prefs.backup_files = backup
else:
logging.info("Backing up files: %s", self.prefs.backup_files)
@@ -24,7 +24,7 @@
if photo_backup_identifier is not None:
self.prefs.photo_backup_identifier = photo_backup_identifier
elif self.prefs.backup_files and self.prefs.backup_device_autodetection:
-@@ -599,7 +599,7 @@ class RapidWindow(QMainWindow):
+@@ -624,7 +624,7 @@ class RapidWindow(QMainWindow):
self.prefs.video_backup_identifier = video_backup_identifier
elif self.prefs.backup_files and self.prefs.backup_device_autodetection:
logging.info("video backup identifier: %s", self.prefs.video_backup_identifier)
@@ -33,7 +33,7 @@
if photo_backup_location is not None:
self.prefs.backup_photo_location = photo_backup_location
elif self.prefs.backup_files and not self.prefs.backup_device_autodetection:
-@@ -934,18 +934,6 @@ class RapidWindow(QMainWindow):
+@@ -939,18 +939,6 @@ class RapidWindow(QMainWindow):
logging.debug("Starting camera hotplug monitor...")
QTimer.singleShot(0, self.cameraHotplugThread.start)
@@ -52,7 +52,7 @@
if self.gvfsControlsMounts:
# Gio.VolumeMonitor must be in the main thread, according to
# Gnome documentation
-@@ -2119,7 +2107,7 @@ class RapidWindow(QMainWindow):
+@@ -2189,7 +2177,7 @@ class RapidWindow(QMainWindow):
select_text=_('Select a destination folder')
)
self.photoDestination.addWidget(self.photoDestinationWidget)
@@ -61,7 +61,7 @@
self.videoDestinationDisplay = DestinationDisplay(
menu=True, file_type=FileType.video, parent=self
)
-@@ -2582,11 +2570,11 @@ class RapidWindow(QMainWindow):
+@@ -2655,11 +2643,11 @@ class RapidWindow(QMainWindow):
body = _(
r"""Please report the problem at <a href="{website}">{website}</a>.<br><br>
@@ -77,7 +77,7 @@
<a href="{config_path}">here</a> to open the configuration directory.
"""
).format(
-@@ -2622,7 +2610,7 @@ class RapidWindow(QMainWindow):
+@@ -2695,7 +2683,7 @@ class RapidWindow(QMainWindow):
:param message: the text to display
:param rich_text: whether it text to display is in HTML format
@@ -86,7 +86,7 @@
localized 'Rapid Photo Downloader'
:return: the message box
"""
-@@ -4652,8 +4640,6 @@ Do you want to proceed with the download?
+@@ -4766,8 +4754,6 @@ Do you want to proceed with the download?
self.sendTerminateToThread(self.backup_controller)
if not self.gvfsControlsMounts:
@@ -95,7 +95,7 @@
self.cameraHotplugThread.quit()
self.cameraHotplugThread.wait()
else:
-@@ -5254,7 +5240,7 @@ Do you want to proceed with the download?
+@@ -5384,7 +5370,7 @@ Do you want to proceed with the download?
After a preference change, rescan already scanned devices
:param ignore_cameras: if True, don't rescan cameras
:param rescan_path: if True, include manually specified paths
@@ -104,7 +104,7 @@
"""
if rescan_path:
-@@ -6243,7 +6229,7 @@ def main():
+@@ -6499,7 +6485,7 @@ def main():
logger = iplogging.setup_main_process_logging(logging_level=logging_level)
logging.info("Rapid Photo Downloader is starting")
@@ -113,7 +113,7 @@
if args.photo_renaming:
photo_rename = args.photo_renaming == 'on'
if photo_rename:
-@@ -6252,7 +6238,7 @@ def main():
+@@ -6508,7 +6494,7 @@ def main():
logging.info("Photo renaming turned off from command line")
else:
photo_rename = None
@@ -122,7 +122,7 @@
if args.video_renaming:
video_rename = args.video_renaming == 'on'
if video_rename:
-@@ -6313,13 +6299,13 @@ def main():
+@@ -6569,13 +6555,13 @@ def main():
logging.info("This Computer path set from command line: %s", this_computer_location)
else:
this_computer_location=None
diff --git a/graphics/rapid-photo-downloader/files/patch-raphodo_storage.py b/graphics/rapid-photo-downloader/files/patch-raphodo_storage.py
index 095d0263348c..93b474f3cbab 100644
--- a/graphics/rapid-photo-downloader/files/patch-raphodo_storage.py
+++ b/graphics/rapid-photo-downloader/files/patch-raphodo_storage.py
@@ -1,4 +1,4 @@
---- raphodo/storage.py.orig 2019-07-09 21:12:19 UTC
+--- raphodo/storage.py.orig 2020-04-17 01:22:23 UTC
+++ raphodo/storage.py
@@ -68,10 +68,9 @@ import xdg
import gi
@@ -10,7 +10,7 @@
-from gi.repository import GUdev, UDisks, GLib
+from gi.repository import GUdev, GLib
- from gettext import gettext as _
+
@@ -170,7 +169,7 @@ def get_media_dir() -> str:
@@ -19,7 +19,7 @@
- if sys.platform.startswith('linux'):
+ if sys.platform.startswith('linux') or sys.platform.startswith('freebsd'):
media_dir = '/media/{}'.format(get_user_name())
- run_media_dir = '/run{}'.format(media_dir)
+ run_media_dir = '/run/media'
distro = get_distro()
@@ -278,7 +277,7 @@ class ValidMounts():
self.validMountFolders, e.g. /media/<USER>, etc.
@@ -30,7 +30,7 @@
raise ("Mounts.setValidMountPoints() not implemented on %s", sys.platform())
else:
try:
-@@ -646,7 +645,7 @@ def get_default_file_manager() -> Tuple[Optional[str],
+@@ -649,7 +648,7 @@ def get_default_file_manager() -> Tuple[Optional[str],
_default_file_manager_probed = True
@@ -39,7 +39,7 @@
cmd = shlex.split('xdg-mime query default inode/directory')
try:
desktop_file = subprocess.check_output(cmd, universal_newlines=True) # type: str
-@@ -791,7 +790,7 @@ def validate_download_folder(path: Optional[str],
+@@ -794,7 +793,7 @@ def validate_download_folder(path: Optional[str],
:param path: path to analyze
:param write_on_waccesss_failure: if os.access reports path is not writable, test
@@ -48,7 +48,7 @@
:return: Tuple indicating validity and path made absolute
>>> validate_download_folder('/some/bogus/and/ridiculous/path')
-@@ -1008,259 +1007,6 @@ class CameraHotplug(QObject):
+@@ -1041,259 +1040,6 @@ class CameraHotplug(QObject):
self.cameraRemoved.emit()
@@ -308,7 +308,7 @@
if have_gio:
class GVolumeMonitor(QObject):
r"""
-@@ -1577,7 +1323,7 @@ def get_mount_size(mount: QStorageInfo) -> Tuple[int,
+@@ -1692,7 +1438,7 @@ def get_mount_size(mount: QStorageInfo) -> Tuple[int,
"""
Uses GIO to get bytes total and bytes free (available) for the mount that a
path is in.
diff --git a/graphics/rapid-photo-downloader/files/patch-raphodo_utilities.py b/graphics/rapid-photo-downloader/files/patch-raphodo_utilities.py
index 7d46505e0be9..9107b42188d5 100644
--- a/graphics/rapid-photo-downloader/files/patch-raphodo_utilities.py
+++ b/graphics/rapid-photo-downloader/files/patch-raphodo_utilities.py
@@ -1,6 +1,6 @@
---- raphodo/utilities.py.orig 2019-08-18 03:58:11 UTC
+--- raphodo/utilities.py.orig 2020-04-17 01:22:23 UTC
+++ raphodo/utilities.py
-@@ -76,10 +76,11 @@ if arrow_version >= parse_version('0.14.3') and arrow_
+@@ -82,10 +82,11 @@ if arrow_version >= parse_version('0.14.3') and arrow_
# Linux specific code to ensure child processes exit when parent dies
# See http://stackoverflow.com/questions/19447603/
# how-to-kill-a-python-child-process-created-with-subprocess-check-output-when-t/
@@ -14,7 +14,7 @@
return callable
-@@ -195,8 +196,8 @@ def show_errors():
+@@ -201,8 +202,8 @@ def show_errors():
# kilobytes, etc.
suffixes = [_('B'), _('KB'), _('MB'), _('GB'), _('TB'), _('PB'), _('EB'), _('ZB'), _('YB')]
@@ -25,7 +25,7 @@
no_decimals: int=2) -> str:
r"""
Humanize display of bytes.
-@@ -382,12 +383,12 @@ def find_mount_point(path: str) -> str:
+@@ -388,12 +389,12 @@ def find_mount_point(path: str) -> str:
Find the mount point of a path
See:
http://stackoverflow.com/questions/4453602/how-to-find-the-mountpoint-a-file-resides-on
@@ -42,7 +42,7 @@
"""
path = os.path.realpath(path)
while not os.path.ismount(path):
-@@ -724,13 +725,13 @@ def _collect_duplicates(basenames, paths):
+@@ -743,13 +744,13 @@ def _collect_duplicates(basenames, paths):
def make_path_end_snippets_unique(*paths) -> List[str]:
r"""
diff --git a/graphics/rapid-photo-downloader/files/patch-setup.py b/graphics/rapid-photo-downloader/files/patch-setup.py
new file mode 100644
index 000000000000..4ad6440f3cdb
--- /dev/null
+++ b/graphics/rapid-photo-downloader/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2020-04-17 01:22:23 UTC
++++ setup.py
+@@ -271,7 +271,6 @@ setup(
+ 'scandir;python_version<"3.5"',
+ 'typing;python_version<"3.5"',
+ 'PyGObject',
+- 'PyQt5',
+ 'babel',
+ ],
+ extras_require={