aboutsummaryrefslogtreecommitdiff
path: root/graphics/rayshade
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-25 18:15:41 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-25 18:15:41 +0000
commit7f8014b6c18f5f97db350bfe6dab11084446d4af (patch)
treea180477e4c7372c59f0db0eb7e65bbe199fde2b2 /graphics/rayshade
parent64249e8f856785cacd656873fce57e3135dce6a4 (diff)
downloadports-7f8014b6c18f5f97db350bfe6dab11084446d4af.tar.gz
ports-7f8014b6c18f5f97db350bfe6dab11084446d4af.zip
- Fix build on -current
- Remove leading article from COMMENT - Support staging PR: ports/184236 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337436
Diffstat (limited to 'graphics/rayshade')
-rw-r--r--graphics/rayshade/Makefile38
-rw-r--r--graphics/rayshade/files/patch-ab24
-rw-r--r--graphics/rayshade/files/patch-etc__rsconvert__lex.l19
-rw-r--r--graphics/rayshade/files/patch-etc__rsconvert__yacc.y10
-rw-r--r--graphics/rayshade/files/patch-libray__libtext__texture.c11
-rw-r--r--graphics/rayshade/files/patch-libshade__lex.l19
-rw-r--r--graphics/rayshade/files/patch-libshade__yacc.y11
7 files changed, 91 insertions, 41 deletions
diff --git a/graphics/rayshade/Makefile b/graphics/rayshade/Makefile
index 5377a01cb135..f30a5b08a027 100644
--- a/graphics/rayshade/Makefile
+++ b/graphics/rayshade/Makefile
@@ -8,20 +8,18 @@ CATEGORIES= graphics
MASTER_SITES= http://ccl.net/cca/software/SOURCES/C/rayshade/ \
http://www.mirrorservice.org/sites/graphics.stanford.edu/pub/rayshade/ \
ftp://graphics.stanford.edu/pub/rayshade/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
-EXTRACT_SUFX= .tar.Z
-.if !defined(NOPORTDOCS)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} guide.ps.Z
-.endif
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${PORTNAME}.${PORTVERSION}.tar.Z ${GUIDE_PS_Z}
DIST_SUBDIR= rayshade
+EXTRACT_ONLY= ${PORTNAME}.${PORTVERSION}.tar.Z
MAINTAINER= ports@FreeBSD.org
-COMMENT= An extensible system for creating ray-traced images
+COMMENT= Extensible system for creating ray-traced images
BUILD_DEPENDS= $(LOCALBASE)/lib/librle.a:${PORTSDIR}/graphics/urt
-WRKSRC= ${WRKDIR}/${PORTNAME}.4.0
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION:R}
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
@@ -31,11 +29,16 @@ PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= bin/rayshade
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+GUIDE_PS_Z= guide.ps.Z
+.endif
+
.if defined(BATCH) || defined(PACKAGE_BUILDING)
CONFIGURE_ARGS= < ${WRKDIR}/config.ans
.endif
-NO_STAGE= yes
pre-configure:
@${SED} -e \
"s,@CFLAGS@,${CFLAGS},g ; \
@@ -45,14 +48,15 @@ pre-configure:
< ${FILESDIR}/config.ans > ${WRKDIR}/config.ans
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/rayshade/rayshade ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/guide.ps.Z ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/Examples/* ${EXAMPLESDIR}
+ (cd ${WRKSRC}/rayshade && ${INSTALL_PROGRAM} rayshade \
+ ${STAGEDIR}${PREFIX}/bin)
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${GUIDE_PS_Z} \
+ ${STAGEDIR}${DOCSDIR})
.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/Examples && ${INSTALL_DATA} * \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/graphics/rayshade/files/patch-ab b/graphics/rayshade/files/patch-ab
deleted file mode 100644
index 4df8936f8ccd..000000000000
--- a/graphics/rayshade/files/patch-ab
+++ /dev/null
@@ -1,24 +0,0 @@
-*** etc/rsconvert/lex.l.orig Sun Mar 8 18:55:39 1998
---- etc/rsconvert/lex.l Sun Mar 8 18:56:05 1998
-***************
-*** 22,27 ****
---- 22,28 ----
- #include "libcommon/common.h"
- #include "y.tab.h"
- %}
-+ %option yylineno
- alpha [a-zA-Z]
- special [\.\_-]
- digit [0-9]
-*** libshade/lex.l.orig Sun Mar 8 18:52:11 1998
---- libshade/lex.l Sun Mar 8 18:53:18 1998
-***************
-*** 29,34 ****
---- 29,35 ----
- #include "y.tab.h"
- extern char *strsave();
- %}
-+ %option yylineno
- alpha [a-zA-Z]
- special [\.\_-]
- digit [0-9]
diff --git a/graphics/rayshade/files/patch-etc__rsconvert__lex.l b/graphics/rayshade/files/patch-etc__rsconvert__lex.l
new file mode 100644
index 000000000000..8c8888341ed3
--- /dev/null
+++ b/graphics/rayshade/files/patch-etc__rsconvert__lex.l
@@ -0,0 +1,19 @@
+--- etc/rsconvert/lex.l.orig 1992-02-10 12:03:54.000000000 +0900
++++ etc/rsconvert/lex.l 2013-05-28 22:55:24.000000000 +0900
+@@ -22,6 +22,7 @@
+ #include "libcommon/common.h"
+ #include "y.tab.h"
+ %}
++%option yylineno
+ alpha [a-zA-Z]
+ special [\.\_-]
+ digit [0-9]
+@@ -113,7 +114,7 @@
+ if ((c = input()) == '/') {
+ WriteChar(c);
+ WriteNewline();
+- return;
++ return FALSE;
+ }
+ unput(c);
+ }
diff --git a/graphics/rayshade/files/patch-etc__rsconvert__yacc.y b/graphics/rayshade/files/patch-etc__rsconvert__yacc.y
new file mode 100644
index 000000000000..4773a6fb527f
--- /dev/null
+++ b/graphics/rayshade/files/patch-etc__rsconvert__yacc.y
@@ -0,0 +1,10 @@
+--- etc/rsconvert/yacc.y.orig
++++ etc/rsconvert/yacc.y
+@@ -14,6 +14,7 @@
+ /* $Id: yacc.y,v 4.0.1.3 92/02/07 11:05:21 cek Exp Locker: cek $ */
+ %{
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "libcommon/common.h"
+
+ #define NEWLINE() WriteNewline()
diff --git a/graphics/rayshade/files/patch-libray__libtext__texture.c b/graphics/rayshade/files/patch-libray__libtext__texture.c
new file mode 100644
index 000000000000..0ad51f4aa9b3
--- /dev/null
+++ b/graphics/rayshade/files/patch-libray__libtext__texture.c
@@ -0,0 +1,11 @@
+--- libray/libtext/texture.c.orig 1992-02-10 12:04:02.000000000 +0900
++++ libray/libtext/texture.c 2013-05-28 22:41:59.000000000 +0900
+@@ -162,7 +162,7 @@
+ *u = ptmp.x;
+ *v = ptmp.y;
+ if (dpdu == (Vector *)NULL || dpdv == (Vector *)NULL)
+- return;
++ return FALSE;
+ /*
+ * Here's the ugly part.
+ * Build initial UVN-->XYZ matrix...
diff --git a/graphics/rayshade/files/patch-libshade__lex.l b/graphics/rayshade/files/patch-libshade__lex.l
new file mode 100644
index 000000000000..1f82dacab387
--- /dev/null
+++ b/graphics/rayshade/files/patch-libshade__lex.l
@@ -0,0 +1,19 @@
+--- libshade/lex.l.orig 1992-02-10 12:04:02.000000000 +0900
++++ libshade/lex.l 2013-05-28 22:45:54.000000000 +0900
+@@ -29,6 +29,7 @@
+ #include "y.tab.h"
+ extern char *strsave();
+ %}
++%option yylineno
+ alpha [a-zA-Z]
+ special [\.\_-]
+ digit [0-9]
+@@ -171,7 +172,7 @@
+ while (input() != '*')
+ ;
+ if ((c = input()) == '/')
+- return;
++ return FALSE;
+ unput(c);
+ }
+ }
diff --git a/graphics/rayshade/files/patch-libshade__yacc.y b/graphics/rayshade/files/patch-libshade__yacc.y
new file mode 100644
index 000000000000..199c907d86c7
--- /dev/null
+++ b/graphics/rayshade/files/patch-libshade__yacc.y
@@ -0,0 +1,11 @@
+--- libshade/yacc.y.orig
++++ libshade/yacc.y
+@@ -13,6 +13,8 @@
+ /* for any purpose. It is provided solely "as is". */
+ /* $Id: yacc.y,v 4.0.1.4 92/01/10 16:29:55 cek Exp Locker: cek $ */
+ %{
++#include <stdlib.h>
++#include <string.h>
+ #include "rayshade.h"
+
+ #include "symtab.h"