aboutsummaryrefslogtreecommitdiff
path: root/graphics/rayshade
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-02-27 14:57:34 +0000
committerSteve Price <steve@FreeBSD.org>2000-02-27 14:57:34 +0000
commite6f2c8ad26e52ceb6b25b759f884b8d51e309e05 (patch)
treefb61fea84736d01f08b9d135d468c16f0440baba /graphics/rayshade
parentbf58fdcdd4e094e04dd3079d28914978a781a627 (diff)
downloadports-e6f2c8ad26e52ceb6b25b759f884b8d51e309e05.tar.gz
ports-e6f2c8ad26e52ceb6b25b759f884b8d51e309e05.zip
- Fix build on -current.
- Remove an unused files (config.h) - Implement an ugly hack (patch-ad) that covers up a (mis)feature in our make(1) on fast machines.
Notes
Notes: svn path=/head/; revision=26361
Diffstat (limited to 'graphics/rayshade')
-rw-r--r--graphics/rayshade/Makefile8
-rw-r--r--graphics/rayshade/files/config.ans6
-rw-r--r--graphics/rayshade/files/patch-aa16
-rw-r--r--graphics/rayshade/files/patch-ac27
-rw-r--r--graphics/rayshade/files/patch-ad15
5 files changed, 59 insertions, 13 deletions
diff --git a/graphics/rayshade/Makefile b/graphics/rayshade/Makefile
index 45e91fca6de4..f4af7f30d747 100644
--- a/graphics/rayshade/Makefile
+++ b/graphics/rayshade/Makefile
@@ -17,12 +17,6 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= $(LOCALBASE)/lib/librle.a:${PORTSDIR}/graphics/urt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400000
-BROKEN= build
-.endif
-
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS+= < ${WRKDIR}/config.ans
@@ -43,4 +37,4 @@ do-install:
$(MKDIR) $(PREFIX)/share/examples/rayshade
$(INSTALL_DATA) $(WRKSRC)/Examples/* $(PREFIX)/share/examples/rayshade
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/rayshade/files/config.ans b/graphics/rayshade/files/config.ans
index 42e9ff80524a..c86c227dc996 100644
--- a/graphics/rayshade/files/config.ans
+++ b/graphics/rayshade/files/config.ans
@@ -4,8 +4,8 @@
-@CFLAGS@
+@CFLAGS@
n
/usr/local/include
@@ -13,8 +13,8 @@ n
-/usr/bin/mkdep
+
yacc
-y
+
diff --git a/graphics/rayshade/files/patch-aa b/graphics/rayshade/files/patch-aa
index 768f2ebbe1e1..750312ef7088 100644
--- a/graphics/rayshade/files/patch-aa
+++ b/graphics/rayshade/files/patch-aa
@@ -1,5 +1,5 @@
-*** Configure.orig Sun Feb 9 22:04:23 1992
---- Configure Sun Mar 8 19:33:26 1998
+*** Configure.orig Sun Feb 9 21:04:23 1992
+--- Configure Sat Feb 26 16:14:13 2000
***************
*** 28,37 ****
PATH=$PATH:'/bsd4.3/usr/bin:/usr/bsd'
@@ -25,6 +25,16 @@
(alias) >/dev/null 2>&1 && \
echo "(I see you are using the Korn shell. Some ksh's blow up on Configure," && \
***************
+*** 660,665 ****
+--- 661,667 ----
+ ;;
+ esac
+ set /usr/ccs/lib/libc.so
++ test -f $1 || set /usr/lib/libc.a
+ test -f $1 || set /usr/lib/libc.so
+ test -f $1 || set /usr/lib/libc.so.[0-9]*
+ eval set \$$#
+***************
*** 872,878 ****
: determine where manual pages are on this system
echo " "
@@ -33,7 +43,7 @@
;;
esac
if test -d "$sysman"; then
---- 873,879 ----
+--- 874,880 ----
: determine where manual pages are on this system
echo " "
case "$sysman" in
diff --git a/graphics/rayshade/files/patch-ac b/graphics/rayshade/files/patch-ac
new file mode 100644
index 000000000000..746d78b7db76
--- /dev/null
+++ b/graphics/rayshade/files/patch-ac
@@ -0,0 +1,27 @@
+*** raypaint/Makefile.SH.orig Sat Mar 28 20:31:28 1998
+--- raypaint/Makefile.SH Sat Mar 28 20:31:55 1998
+***************
+*** 55,65 ****
+
+ #
+ # If using X11, use:
+! #GRAPHICSLIB = -lX11
+
+ #
+ # If you are using GL, use:
+! GRAPHICSLIB = -lgl_s
+
+ LIBRAY = $(LIBRAYDIR)/libray.a
+ LIBSHADE = $(LIBSHADEDIR)/libshade.a
+--- 55,65 ----
+
+ #
+ # If using X11, use:
+! GRAPHICSLIB = -lX11
+
+ #
+ # If you are using GL, use:
+! #GRAPHICSLIB = -lgl_s
+
+ LIBRAY = $(LIBRAYDIR)/libray.a
+ LIBSHADE = $(LIBSHADEDIR)/libshade.a
diff --git a/graphics/rayshade/files/patch-ad b/graphics/rayshade/files/patch-ad
new file mode 100644
index 000000000000..862e271a383a
--- /dev/null
+++ b/graphics/rayshade/files/patch-ad
@@ -0,0 +1,15 @@
+On really fast machines some of the .o files aren't being added to
+libray.a because they are generated so fast that make(1) thinks the
+library is up-to-date. Marvel at the horrific hack below.
+
+--- libray/Makefile.orig Sat Feb 26 16:41:28 2000
++++ libray/Makefile Sat Feb 26 16:42:36 2000
+@@ -12,6 +12,8 @@
+ for i in $(STUFF); do \
+ (cd $$i && $(MAKE)); \
+ done
++ rm -f libray.a
++ ar cur libray.a `find . -name '*.o'`
+
+ #
+ # Have to keep clean/depend separete so