aboutsummaryrefslogtreecommitdiff
path: root/graphics/reallyslick/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-28 23:49:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-28 23:49:33 +0000
commitad5af0448cb4c018671a93203fe32409e197b68a (patch)
tree0385c41748bc640aa189005053f46c4a46e0750b /graphics/reallyslick/Makefile
parent2c3b1de4d4a7ff5e5d7704b96c616814a58c2994 (diff)
downloadports-ad5af0448cb4c018671a93203fe32409e197b68a.tar.gz
ports-ad5af0448cb4c018671a93203fe32409e197b68a.zip
Notes
Diffstat (limited to 'graphics/reallyslick/Makefile')
-rw-r--r--graphics/reallyslick/Makefile63
1 files changed, 33 insertions, 30 deletions
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 46541ba52691..1cf3606f25ba 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= reallyslick
-PORTVERSION= 0.8.1
-PORTREVISION= 5
+PORTVERSION= 0.9.0
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= rss-glx
+MASTER_SITES= SF/rss-glx
DISTNAME= rss-glx_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -18,32 +16,37 @@ COMMENT= OpenGL screensaver collection
LIB_DEPENDS= MagickWand.2:${PORTSDIR}/graphics/ImageMagick
+OPTIONS= FREEALUT "Enable freealut support" off \
+ GLEW "Enable GLEW support" off
+
USE_BZIP2= yes
-USE_GL= yes
+USE_GL= glu
+USE_GNOME= gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15:env
-
-CPPFLAGS+= -I${LOCALBASE}/include `Magick-config --cflags`
-LDFLAGS+= -L${LOCALBASE}/lib `Magick-config --libs`
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-
-MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 euphoria.1 fieldlines.1 flocks.1 \
- flux.1 helios.1 hufo_smoke.1 hufo_tunnel.1 lattice.1 matrixview.1 \
- plasma.1 skyrocket.1 solarwinds.1 spirographx.1 sundancer2.1
-
-post-patch:
-.for file in config.guess config.sub ltmain.sh
- ${RM} ${WRKSRC}/${file}
- ${LN} -s ${LOCALBASE}/share/libtool/${file} ${WRKSRC}
-.endfor
-.for file in oglc_src/Makefile.in other_src/Makefile.in \
- reallyslick/c_src/Makefile.in reallyslick/cpp_src/Makefile.in
- @${REINPLACE_CMD} -E -e 's|(@LIBS@)|\1 -lXext|' ${WRKSRC}/${file}
-.endfor
-# fix lib detection
- @${REINPLACE_CMD} -E -e 's@^(LIBS.*-l(GL|MesaGL|GLU))@\1 -lXext@' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
-.include <bsd.port.mk>
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 drempels.1 \
+ euphoria.1 feedback.1 fieldlines.1 flocks.1 flux.1 \
+ helios.1 hufo_smoke.1 hufo_tunnel.1 hyperspace.1 lattice.1 \
+ lorenz.1 matrixview.1 plasma.1 skyrocket.1 solarwinds.1 \
+ spirographx.1 sundancer2.1
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FREEALUT)
+LIB_DEPENDS+= alut.1:${PORTSDIR}/audio/freealut
+.else
+CONFIGURE_ARGS+= --disable-sound
+.endif
+
+.if defined(WITH_GLEW)
+LIB_DEPENDS+= GLEW.1:${PORTSDIR}/graphics/glew
+.else
+CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
+.endif
+
+.include <bsd.port.post.mk>