aboutsummaryrefslogtreecommitdiff
path: root/graphics/repng2jpeg
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:20:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:20:42 +0000
commitffdd6c4e867654f8cf34a09cc717258d7f2a13d8 (patch)
tree04a569d8fff55d78878430482fad214b36e06424 /graphics/repng2jpeg
parent9c475064eedaeb2b146fa7e20451c20b65296207 (diff)
downloadports-ffdd6c4e867654f8cf34a09cc717258d7f2a13d8.tar.gz
ports-ffdd6c4e867654f8cf34a09cc717258d7f2a13d8.zip
[NEW PORT] graphics/repng2jpeg: Tool to recompress JPEG/PNG/GIF
Tool to recompress JPEG/PNG/GIF. WWW: http://sugachan.dip.jp/obsolete/ext/ PR: ports/126570 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Notes
Notes: svn path=/head/; revision=218707
Diffstat (limited to 'graphics/repng2jpeg')
-rw-r--r--graphics/repng2jpeg/Makefile32
-rw-r--r--graphics/repng2jpeg/distinfo3
-rw-r--r--graphics/repng2jpeg/pkg-descr3
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/repng2jpeg/Makefile b/graphics/repng2jpeg/Makefile
new file mode 100644
index 000000000000..814ebce4f6d2
--- /dev/null
+++ b/graphics/repng2jpeg/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: repng2jpeg
+# Date created: 2008-08-17
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= repng2jpeg
+PORTVERSION= 1.0.4
+CATEGORIES= graphics
+MASTER_SITES= http://sugachan.dip.jp/obsolete/arch/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Tool to recompress JPEG/PNG/GIF
+
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgd
+
+PLIST_FILES= bin/repng2jpeg
+RESTRICTED= No license text in tarball and website
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/src/repng2jpeg \
+ ${WRKSRC}/src/repng2jpeg.c ${LDFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/repng2jpeg ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/repng2jpeg/distinfo b/graphics/repng2jpeg/distinfo
new file mode 100644
index 000000000000..18e5f0e3f773
--- /dev/null
+++ b/graphics/repng2jpeg/distinfo
@@ -0,0 +1,3 @@
+MD5 (repng2jpeg_1.0.4.tar.gz) = 8f5aab8af97063f075913115c7be5c5b
+SHA256 (repng2jpeg_1.0.4.tar.gz) = d1f02dc6d698ebcd38aaf6c8ee149101fb5148aafb9783930eb037e2967adb90
+SIZE (repng2jpeg_1.0.4.tar.gz) = 1839766
diff --git a/graphics/repng2jpeg/pkg-descr b/graphics/repng2jpeg/pkg-descr
new file mode 100644
index 000000000000..971153b35408
--- /dev/null
+++ b/graphics/repng2jpeg/pkg-descr
@@ -0,0 +1,3 @@
+Tool to recompress JPEG/PNG/GIF.
+
+WWW: http://sugachan.dip.jp/obsolete/ext/