aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-ming
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-10-25 04:32:36 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-10-25 04:32:36 +0000
commit315855ac364702ef5fcaecb83f00afe55bcab8e7 (patch)
tree74f6e42bd752280ec0873cfa83888e04e5ace0c9 /graphics/ruby-ming
parent66743463bd352c1ad4917b749dca3b89f7431f18 (diff)
downloadports-315855ac364702ef5fcaecb83f00afe55bcab8e7.tar.gz
ports-315855ac364702ef5fcaecb83f00afe55bcab8e7.zip
Notes
Diffstat (limited to 'graphics/ruby-ming')
-rw-r--r--graphics/ruby-ming/Makefile7
-rw-r--r--graphics/ruby-ming/files/patch-depend18
2 files changed, 10 insertions, 15 deletions
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index 81c228db7ef2..e6ec4632e06d 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.2e
-PORTREVISION= 1
+PORTVERSION= 0.0.3a
CATEGORIES= graphics ruby
MASTER_SITES= http://www.opaque.net/ming/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
-LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.1:${PORTSDIR}/graphics/ming
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -33,7 +32,7 @@ SWIG= swig1.3
EXAMPLES= shape.rb test.rb
post-extract:
- ${LN} -sf ${WRKSRC}/../py_ext/*.i ${WRKSRC}/
+ ${LN} -sf ../ming.i ${WRKSRC}/
post-install:
${INSTALL_DATA} ${WRKSRC}/ming.rb ${RUBY_SITELIBDIR}/
diff --git a/graphics/ruby-ming/files/patch-depend b/graphics/ruby-ming/files/patch-depend
index a16f374050bf..2cddb2e4a07c 100644
--- a/graphics/ruby-ming/files/patch-depend
+++ b/graphics/ruby-ming/files/patch-depend
@@ -1,17 +1,13 @@
---- depend.orig Fri Oct 13 15:26:31 2000
-+++ depend Tue Oct 17 17:46:26 2000
-@@ -1,4 +1,4 @@
--SWIGINC= ../py_ext
-+SWIGINC= .
+--- depend.orig Wed Oct 25 07:02:39 2000
++++ depend Wed Oct 25 13:23:57 2000
+@@ -4,8 +4,8 @@
- OBJS+= ming_wrap.o
-
-@@ -7,7 +7,7 @@
ming_wrap.o: ming_wrap.c
- ming_wrap.c: ${SWIGINC}/blocklist.i ${SWIGINC}/blocktypes.i ${SWIGINC}/ming.i ${SWIGINC}/swf.i
-- swig -I${SWIGINC} -ruby ${SWIGINC}/ming.i
-+ ${SWIG} -I${SWIGINC} -ruby ${SWIGINC}/ming.i
+-ming_wrap.c: ../ming.i
+- swig -I.. -ruby ming.i
++ming_wrap.c: ming.i
++ ${SWIG} -ruby ming.i
clean: clean_local