aboutsummaryrefslogtreecommitdiff
path: root/graphics/rubygem-scruffy
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /graphics/rubygem-scruffy
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
downloadports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.gz
ports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Notes
Notes: svn path=/head/; revision=210636
Diffstat (limited to 'graphics/rubygem-scruffy')
-rw-r--r--graphics/rubygem-scruffy/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/rubygem-scruffy/Makefile b/graphics/rubygem-scruffy/Makefile
index d6b2b6a0dc97..42c4fe716d26 100644
--- a/graphics/rubygem-scruffy/Makefile
+++ b/graphics/rubygem-scruffy/Makefile
@@ -17,6 +17,7 @@ COMMENT= Beautiful Graphs for Ruby
RUN_DEPENDS= rubygem-builder>=2.0.0:${PORTSDIR}/devel/rubygem-builder
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>