aboutsummaryrefslogtreecommitdiff
path: root/graphics/s2
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:30:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:52 +0000
commit9b1ac61671399c2eed1da042e1c2c665666bf891 (patch)
tree166fd4530b85c3e58bc528b32602dd56d891a92f /graphics/s2
parentae8eee22d8248ad2359cd264eadadfc3884618d5 (diff)
downloadports-9b1ac61671399c2eed1da042e1c2c665666bf891.tar.gz
ports-9b1ac61671399c2eed1da042e1c2c665666bf891.zip
graphics/s2: Update to 0.11.0
Diffstat (limited to 'graphics/s2')
-rw-r--r--graphics/s2/Makefile9
-rw-r--r--graphics/s2/distinfo6
-rw-r--r--graphics/s2/files/patch-CMakeLists.txt11
-rw-r--r--graphics/s2/files/patch-gflags17
-rw-r--r--graphics/s2/files/patch-src_s2_util_math_exactfloat_exactfloat.cc13
-rw-r--r--graphics/s2/pkg-plist13
6 files changed, 19 insertions, 50 deletions
diff --git a/graphics/s2/Makefile b/graphics/s2/Makefile
index 6e2d9d9faea5..bb7c57aa5e2a 100644
--- a/graphics/s2/Makefile
+++ b/graphics/s2/Makefile
@@ -1,7 +1,6 @@
PORTNAME= s2
-PORTVERSION= 0.10.0
+PORTVERSION= 0.11.1
DISTVERSIONPREFIX= v
-PORTREVISION= 5
CATEGORIES= graphics
MAINTAINER= sunpoet@FreeBSD.org
@@ -15,13 +14,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
NOT_FOR_ARCHS= i386
NOT_FOR_ARCHS_REASON= is currently 64-bit only
-LIB_DEPENDS= libabsl_base.so:devel/abseil \
- libgtest.so:devel/googletest
+LIB_DEPENDS= libabsl_base.so:devel/abseil
USES= cmake compiler:c++17-lang localbase ssl
+CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17
+CMAKE_OFF= BUILD_TESTS S2_USE_SYSTEM_INCLUDES WITH_PYTHON
CMAKE_ON= BUILD_SHARED_LIBS
-CMAKE_OFF= WITH_PYTHON
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/graphics/s2/distinfo b/graphics/s2/distinfo
index 904934a03b44..47966dbe5f20 100644
--- a/graphics/s2/distinfo
+++ b/graphics/s2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650970063
-SHA256 (google-s2geometry-v0.10.0_GH0.tar.gz) = 1c17b04f1ea20ed09a67a83151ddd5d8529716f509dde49a8190618d70532a3d
-SIZE (google-s2geometry-v0.10.0_GH0.tar.gz) = 1110687
+TIMESTAMP = 1708448986
+SHA256 (google-s2geometry-v0.11.1_GH0.tar.gz) = bdbeb8ebdb88fa934257caf81bb44b55711617a3ab4fdec2c3cfd6cc31b61734
+SIZE (google-s2geometry-v0.11.1_GH0.tar.gz) = 1180820
diff --git a/graphics/s2/files/patch-CMakeLists.txt b/graphics/s2/files/patch-CMakeLists.txt
deleted file mode 100644
index 914e384ef56c..000000000000
--- a/graphics/s2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2022-04-01 11:53:29 UTC
-+++ CMakeLists.txt
-@@ -19,7 +19,7 @@ endif()
- # undefined symbol errors since ABSL_HAVE_STD_STRING_VIEW etc will
- # end up defined differently. There is probably a better way to achieve
- # this than assuming what absl used.
--set(CMAKE_CXX_STANDARD 11)
-+set(CMAKE_CXX_STANDARD 17)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
- # No compiler-specific extensions, i.e. -std=c++11, not -std=gnu++11.
- set(CMAKE_CXX_EXTENSIONS OFF)
diff --git a/graphics/s2/files/patch-gflags b/graphics/s2/files/patch-gflags
deleted file mode 100644
index ca5e9a7a610f..000000000000
--- a/graphics/s2/files/patch-gflags
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/s2/base/commandlineflags.h.orig 2022-04-01 11:53:29 UTC
-+++ src/s2/base/commandlineflags.h
-@@ -44,10 +44,10 @@
-
- // gflags has its own int32 definitions.
- namespace absl {
--inline int32 GetFlag(google::int32 flag) { return flag; }
--inline int64 GetFlag(google::int64 flag) { return flag; }
--inline void SetFlag(google::int32* f, google::int32 v) { *f = v; }
--inline void SetFlag(google::int64* f, google::int64 v) { *f = v; }
-+inline int32 GetFlag(gflags::int32 flag) { return flag; }
-+inline int64 GetFlag(gflags::int64 flag) { return flag; }
-+inline void SetFlag(gflags::int32* f, gflags::int32 v) { *f = v; }
-+inline void SetFlag(gflags::int64* f, gflags::int64 v) { *f = v; }
- } // namespace absl
-
- #else // !defined(S2_USE_GFLAGS)
diff --git a/graphics/s2/files/patch-src_s2_util_math_exactfloat_exactfloat.cc b/graphics/s2/files/patch-src_s2_util_math_exactfloat_exactfloat.cc
deleted file mode 100644
index 111df840b8f0..000000000000
--- a/graphics/s2/files/patch-src_s2_util_math_exactfloat_exactfloat.cc
+++ /dev/null
@@ -1,13 +0,0 @@
-Reference: https://github.com/google/s2geometry/commit/7a40135059545396237a0199c558d749fe3be0b1
-
---- src/s2/util/math/exactfloat/exactfloat.cc.orig 2022-05-24 22:12:24 UTC
-+++ src/s2/util/math/exactfloat/exactfloat.cc
-@@ -141,7 +141,7 @@ inline static uint64 BN_ext_get_uint64(const BIGNUM* b
- #ifdef IS_LITTLE_ENDIAN
- S2_CHECK_EQ(BN_bn2lebinpad(bn, reinterpret_cast<unsigned char*>(&r),
- sizeof(r)), sizeof(r));
--#elif IS_BIG_ENDIAN
-+#elif defined(IS_BIG_ENDIAN)
- S2_CHECK_EQ(BN_bn2binpad(bn, reinterpret_cast<unsigned char*>(&r),
- sizeof(r)), sizeof(r));
- #else
diff --git a/graphics/s2/pkg-plist b/graphics/s2/pkg-plist
index 0ff8f9d4bad7..05ce02b516ed 100644
--- a/graphics/s2/pkg-plist
+++ b/graphics/s2/pkg-plist
@@ -1,6 +1,7 @@
include/s2/_fp_contract_off.h
include/s2/base/casts.h
include/s2/base/commandlineflags.h
+include/s2/base/commandlineflags_declare.h
include/s2/base/integral_types.h
include/s2/base/log_severity.h
include/s2/base/logging.h
@@ -40,6 +41,9 @@ include/s2/s2cap.h
include/s2/s2cell.h
include/s2/s2cell_id.h
include/s2/s2cell_index.h
+include/s2/s2cell_iterator.h
+include/s2/s2cell_iterator_join.h
+include/s2/s2cell_range_iterator.h
include/s2/s2cell_union.h
include/s2/s2centroids.h
include/s2/s2closest_cell_query.h
@@ -48,6 +52,7 @@ include/s2/s2closest_edge_query.h
include/s2/s2closest_edge_query_base.h
include/s2/s2closest_point_query.h
include/s2/s2closest_point_query_base.h
+include/s2/s2coder.h
include/s2/s2contains_point_query.h
include/s2/s2contains_vertex_query.h
include/s2/s2convex_hull_query.h
@@ -66,6 +71,7 @@ include/s2/s2edge_tessellator.h
include/s2/s2edge_vector_shape.h
include/s2/s2error.h
include/s2/s2furthest_edge_query.h
+include/s2/s2hausdorff_distance_query.h
include/s2/s2latlng.h
include/s2/s2latlng_rect.h
include/s2/s2latlng_rect_bounder.h
@@ -106,6 +112,7 @@ include/s2/s2shape_index.h
include/s2/s2shape_index_buffered_region.h
include/s2/s2shape_index_region.h
include/s2/s2shape_measures.h
+include/s2/s2shape_nesting_query.h
include/s2/s2shapeutil_build_polygon_boundaries.h
include/s2/s2shapeutil_coding.h
include/s2/s2shapeutil_contains_brute_force.h
@@ -113,7 +120,6 @@ include/s2/s2shapeutil_conversion.h
include/s2/s2shapeutil_count_edges.h
include/s2/s2shapeutil_edge_iterator.h
include/s2/s2shapeutil_get_reference_point.h
-include/s2/s2shapeutil_range_iterator.h
include/s2/s2shapeutil_shape_edge.h
include/s2/s2shapeutil_shape_edge_id.h
include/s2/s2shapeutil_testing.h
@@ -124,7 +130,9 @@ include/s2/s2wedge_relations.h
include/s2/s2winding_operation.h
include/s2/s2wrapped_shape.h
include/s2/sequence_lexicon.h
+include/s2/testing/gtest_prod.h
include/s2/thread_testing.h
+include/s2/util/bitmap/bitmap.h
include/s2/util/bits/bits.h
include/s2/util/coding/coder.h
include/s2/util/coding/varint.h
@@ -147,3 +155,6 @@ lib/libs2.so.0
lib/libs2.so.%%PORTVERSION%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point_index.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/term_index.cc
+%%DATADIR%%/s2Config.cmake
+%%DATADIR%%/s2Targets-%%CMAKE_BUILD_TYPE%%.cmake
+%%DATADIR%%/s2Targets.cmake