aboutsummaryrefslogtreecommitdiff
path: root/graphics/s2tc
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-03-20 19:38:08 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-03-20 19:38:08 +0000
commit347c925ee59d4ed37e27c0dda29c249ad4666a53 (patch)
tree998c245af16e17d6b1fe0b466d9284306c5a260f /graphics/s2tc
parent4d373c85e5103112eb5415c9d23460c970fd9431 (diff)
downloadports-347c925ee59d4ed37e27c0dda29c249ad4666a53.tar.gz
ports-347c925ee59d4ed37e27c0dda29c249ad4666a53.zip
graphics/s2tc: add new port.
Add a port that implements a subset of the Color Cell Compression texture compression scheme.
Notes
Notes: svn path=/head/; revision=411515
Diffstat (limited to 'graphics/s2tc')
-rw-r--r--graphics/s2tc/Makefile26
-rw-r--r--graphics/s2tc/distinfo2
-rw-r--r--graphics/s2tc/files/patch-Makefile.am11
-rw-r--r--graphics/s2tc/pkg-descr14
-rw-r--r--graphics/s2tc/pkg-plist9
5 files changed, 62 insertions, 0 deletions
diff --git a/graphics/s2tc/Makefile b/graphics/s2tc/Makefile
new file mode 100644
index 000000000000..3a3457a6700e
--- /dev/null
+++ b/graphics/s2tc/Makefile
@@ -0,0 +1,26 @@
+# Created by: David Naylor <dbn@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= s2tc
+PORTVERSION= 1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= dbn@FreeBSD.org
+COMMENT= S2TC is a subset of a wellknown texture compression scheme
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf libtool
+USE_GL= gl
+USE_GITHUB= yes
+
+GH_ACCOUNT= divVerent
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/graphics/s2tc/distinfo b/graphics/s2tc/distinfo
new file mode 100644
index 000000000000..e2698262c221
--- /dev/null
+++ b/graphics/s2tc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (divVerent-s2tc-v1.0_GH0.tar.gz) = a21c5babd3810af4f7d4e8099e830f545b4e5f5dc0aadf375ed09d23566c6e45
+SIZE (divVerent-s2tc-v1.0_GH0.tar.gz) = 1397232
diff --git a/graphics/s2tc/files/patch-Makefile.am b/graphics/s2tc/files/patch-Makefile.am
new file mode 100644
index 000000000000..8ec342d31f68
--- /dev/null
+++ b/graphics/s2tc/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2016-03-20 18:59:03 UTC
++++ Makefile.am
+@@ -10,8 +10,6 @@ s2tc_from_s3tc_SOURCES = s2tc_from_s3tc.
+ s2tc_compress_SOURCES = s2tc_compress.cpp txc_dxtn.h s2tc_license.h
+ s2tc_decompress_SOURCES = s2tc_decompress.cpp txc_dxtn.h s2tc_license.h
+ if ENABLE_RUNTIME_LINKING
+-s2tc_compress_LDADD = -ldl
+-s2tc_decompress_LDADD = -ldl
+ else
+ if ENABLE_LIB
+ s2tc_compress_LDADD = libtxc_dxtn.la
diff --git a/graphics/s2tc/pkg-descr b/graphics/s2tc/pkg-descr
new file mode 100644
index 000000000000..4603ad90e96c
--- /dev/null
+++ b/graphics/s2tc/pkg-descr
@@ -0,0 +1,14 @@
+S2TC's format specification is very easy to implement, so it is not hard to make
+a working compressor or decompressor for it. It is based on Color Cell
+Compression[1] from 1986, and decoding is done entirely using the methods from
+there. Encoding is done using a search and refinement method that is derived
+from the methods described in that paper.
+
+This also makes this format a great platform for learning about texture
+compression and how to tune a compressor for best quality.
+
+S2TC is especially well suited for runtime (on-load) compression of textures, as
+it is - in low quality settings - way faster than any other texture compressors
+out there.
+
+WWW: https://github.com/divVerent/s2tc/wiki
diff --git a/graphics/s2tc/pkg-plist b/graphics/s2tc/pkg-plist
new file mode 100644
index 000000000000..c9619b0bdc34
--- /dev/null
+++ b/graphics/s2tc/pkg-plist
@@ -0,0 +1,9 @@
+bin/s2tc_compress
+bin/s2tc_decompress
+bin/s2tc_from_s3tc
+include/txc_dxtn.h
+lib/libtxc_dxtn.a
+lib/libtxc_dxtn.so
+lib/libtxc_dxtn.so.0
+lib/libtxc_dxtn.so.0.0.0
+lib/pkgconfig/txc_dxtn.pc