aboutsummaryrefslogtreecommitdiff
path: root/graphics/sam2p/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-11 19:59:27 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-11 19:59:27 +0000
commit7de0cbc2b5849d54b633cbd2a66984fa29433cd2 (patch)
treeb9662c1e02125d65a6cfdf0a48badd9cd31bdc57 /graphics/sam2p/Makefile
parent9df96dcadeabbc49e48be7822fdab3e533b6777a (diff)
downloadports-7de0cbc2b5849d54b633cbd2a66984fa29433cd2.tar.gz
ports-7de0cbc2b5849d54b633cbd2a66984fa29433cd2.zip
Notes
Diffstat (limited to 'graphics/sam2p/Makefile')
-rw-r--r--graphics/sam2p/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
index c2cfa28f6efd..2949c4d330ee 100644
--- a/graphics/sam2p/Makefile
+++ b/graphics/sam2p/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sam2p
-PORTVERSION= 0.49.1
-PORTREVISION= 1
+PORTVERSION= 0.49.2
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
@@ -17,31 +16,29 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
cjpeg:${PORTSDIR}/graphics/jpeg \
tif22pnm:${PORTSDIR}/graphics/tif22pnm
-USES= perl5
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USES= gmake perl5
USE_PERL5= build
+USE_GCC= any
USE_GHOSTSCRIPT_RUN= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_pts_bash="${SH}"
-MAKE_ARGS= CXXX="${CXX}" LDALL="${CXX}" CXXFLAGSB="${CXXFLAGS}"
+CONFIGURE_ARGS= --enable-gif
+MAKE_ARGS= CXXX="${CXX}" LDALL="${CXX}" CXXFLAGSB="${CXXFLAGS}" CC=${CC} CXX=${CXX}
ALL_TARGET= ${PORTNAME}
-PORTDOCS= README
+PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>