aboutsummaryrefslogtreecommitdiff
path: root/graphics/sam2p
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-27 01:23:34 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-27 01:23:34 +0000
commit03f9e75859ac4003442106882943e05acb7ced45 (patch)
tree7d1012905b596866eb88b175efd1fba50ba9c3c8 /graphics/sam2p
parent421767bd88527645cd4058a75e4ccfc620acf467 (diff)
downloadports-03f9e75859ac4003442106882943e05acb7ced45.tar.gz
ports-03f9e75859ac4003442106882943e05acb7ced45.zip
- Add LICENSE_FILE
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=411971
Diffstat (limited to 'graphics/sam2p')
-rw-r--r--graphics/sam2p/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
index 96a465c1b2d2..1594c0e3527b 100644
--- a/graphics/sam2p/Makefile
+++ b/graphics/sam2p/Makefile
@@ -12,12 +12,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Converts raster (bitmap) image formats into PS or PDF files
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
tif22pnm:${PORTSDIR}/graphics/tif22pnm
-OPTIONS_DEFINE= DOCS EXAMPLES
-
USES= ghostscript:run gmake jpeg:run perl5
USE_PERL5= build
USE_GCC= any
@@ -31,12 +30,16 @@ PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= bin/${PORTNAME}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
- ${STAGEDIR}${PREFIX}/bin)
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR})
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . \
${STAGEDIR}${EXAMPLESDIR})