aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-08-24 07:47:16 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-08-24 07:47:16 +0000
commit0460e9117eba36fbb383a3144940caf1786926b8 (patch)
tree0afccbc68cf1c3d79ec9ff1eae59810b016bf572 /graphics/sane-backends
parent890819ebb7c486cfe0791be5c6969faaa409e9b6 (diff)
downloadports-0460e9117eba36fbb383a3144940caf1786926b8.tar.gz
ports-0460e9117eba36fbb383a3144940caf1786926b8.zip
graphics/sane-backends: Update to 1.0.31
Enable more desktop friendly options by default which adds support for cameras, AirScan/eSCL devices. Changes: https://gitlab.com/sane-project/backends/-/tags/1.0.31
Notes
Notes: svn path=/head/; revision=546055
Diffstat (limited to 'graphics/sane-backends')
-rw-r--r--graphics/sane-backends/Makefile23
-rw-r--r--graphics/sane-backends/distinfo6
-rw-r--r--graphics/sane-backends/files/patch-backend_Makefile.in8
-rw-r--r--graphics/sane-backends/files/patch-backend_epsonds.c11
-rw-r--r--graphics/sane-backends/files/patch-backend_genesys_low.cpp19
-rw-r--r--graphics/sane-backends/files/patch-backend_pixma_pixma__bjnp.c21
-rw-r--r--graphics/sane-backends/files/patch-backend_ricoh2__buffer.c11
-rw-r--r--graphics/sane-backends/files/patch-backend_umax__pp__low.c13
-rw-r--r--graphics/sane-backends/files/patch-backend_v4l.c22
-rw-r--r--graphics/sane-backends/files/patch-configure8
-rw-r--r--graphics/sane-backends/files/patch-tools_sane-desc.c13
-rw-r--r--graphics/sane-backends/pkg-plist5
12 files changed, 27 insertions, 133 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 0881642551df..8d0818b76449 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= sane-backends
-PORTVERSION= 1.0.30
+PORTVERSION= 1.0.31
CATEGORIES= graphics
-MASTER_SITES= https://gitlab.com/sane-project/backends/uploads/c3dd60c9e054b5dee1e7b01a7edc98b0/
+MASTER_SITES= https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/
MAINTAINER= tobik@FreeBSD.org
COMMENT= API for accessing scanners, digital cameras, frame grabbers, etc
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= compiler:c++11-lang gmake gnome jpeg libtool localbase pathfix \
- pkgconfig
+USES= compiler:c++11-lang gmake gnome jpeg libtool localbase:ldflags \
+ pathfix pkgconfig
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_RC_SUBR= saned
@@ -24,7 +24,6 @@ USE_RC_SUBR= saned
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-locking \
--enable-pthread \
- --without-api-spec \
--without-systemd
INSTALL_TARGET= install-strip
@@ -36,18 +35,19 @@ GROUPS= saned
PLIST_SUB= SOVERSION=${PORTVERSION}
OPTIONS_DEFINE= AVAHI DOCS GPHOTO IEEE1284 IPV6 NLS SNMP USB V4L
-OPTIONS_DEFAULT= USB
+OPTIONS_DEFAULT= AVAHI GPHOTO USB
OPTIONS_SUB= yes
IEEE1284_DESC= Parallel port support via libieee1284
USB_DESC= USB support
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app \
- libcurl.so:ftp/curl
-AVAHI_CONFIGURE_ENABLE= avahi
-AVAHI_CONFIGURE_WITH= libcurl
+ libcurl.so:ftp/curl \
+ libpoppler-glib.so:graphics/poppler-glib
+AVAHI_USE= GNOME=cairo,glib20
+AVAHI_CONFIGURE_WITH= avahi libcurl
GPHOTO_LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2
-GPHOTO_CONFIGURE_OFF= --with-gphoto2=no
+GPHOTO_CONFIGURE_WITH= gphoto2
IEEE1284_LIB_DEPENDS= libieee1284.so:sysutils/libieee1284
IEEE1284_CONFIGURE_ENV_OFF= sane_cv_use_libieee1284=no
IPV6_CONFIGURE_ENABLE= ipv6
@@ -55,8 +55,7 @@ NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_CONFIGURE_WITH= snmp
-USB_CONFIGURE_OFF= --with-usb=no
-USB_CONFIGURE_ON= --with-usb
+USB_CONFIGURE_WITH= usb
V4L_LIB_DEPENDS= libv4l1.so:multimedia/libv4l
V4L_CONFIGURE_WITH= v4l
diff --git a/graphics/sane-backends/distinfo b/graphics/sane-backends/distinfo
index 6806286ad550..d694d3b9c1f1 100644
--- a/graphics/sane-backends/distinfo
+++ b/graphics/sane-backends/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589738297
-SHA256 (sane-backends-1.0.30.tar.gz) = 3f5d96a9c47f6124a46bb577c776bbc4896dd17b9203d8bfbc7fe8cbbcf279a3
-SIZE (sane-backends-1.0.30.tar.gz) = 7204519
+TIMESTAMP = 1598185199
+SHA256 (sane-backends-1.0.31.tar.gz) = 4a3b10fcb398ed854777d979498645edfe66fcac2f2fd2b9117a79ff45e2a5aa
+SIZE (sane-backends-1.0.31.tar.gz) = 7301484
diff --git a/graphics/sane-backends/files/patch-backend_Makefile.in b/graphics/sane-backends/files/patch-backend_Makefile.in
index 09ec940291a7..203efcc1d2ed 100644
--- a/graphics/sane-backends/files/patch-backend_Makefile.in
+++ b/graphics/sane-backends/files/patch-backend_Makefile.in
@@ -1,6 +1,6 @@
---- backend/Makefile.in.orig 2020-05-17 17:59:11 UTC
+--- backend/Makefile.in.orig 2020-08-23 12:27:20 UTC
+++ backend/Makefile.in
-@@ -1645,7 +1645,7 @@ AM_V_at = $(am__v_at_@AM_V@)
+@@ -1667,7 +1667,7 @@ AM_V_at = $(am__v_at_@AM_V@)
am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
am__v_at_0 = @
am__v_at_1 =
@@ -9,7 +9,7 @@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__maybe_remake_depfiles = depfiles
am__depfiles_remade = ./$(DEPDIR)/libabaton_la-abaton.Plo \
-@@ -7174,7 +7174,7 @@ install-becfg: becfg
+@@ -7276,7 +7276,7 @@ install-becfg: becfg
@# installed library in $(sanelibdir) to $(sanelibdir)/libsane.*.
@# Having two libsane's can cause issues so get rid of it.
-rm -f $(DESTDIR)$(sanelibdir)/libsane.*
@@ -18,7 +18,7 @@
test -z "$(configdir)/dll.d" || $(MKDIR_P) "$(DESTDIR)$(configdir)/dll.d"
@list="$(BACKEND_CONFS_ENABLED) saned.conf dll.conf"; for cfg in $$list; do \
if test ! -r $${cfg}; then continue; fi; \
-@@ -7182,7 +7182,7 @@ install-becfg: becfg
+@@ -7284,7 +7284,7 @@ install-becfg: becfg
echo NOT overwriting $${cfg} in $(configdir)...; \
else \
echo installing $${cfg} in $(configdir)/$${cfg}...; \
diff --git a/graphics/sane-backends/files/patch-backend_epsonds.c b/graphics/sane-backends/files/patch-backend_epsonds.c
deleted file mode 100644
index cccfbb3361a1..000000000000
--- a/graphics/sane-backends/files/patch-backend_epsonds.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- backend/epsonds.c.orig 2019-10-09 14:38:54 UTC
-+++ backend/epsonds.c
-@@ -48,6 +48,8 @@
- # include <sys/time.h>
- #endif
- #include <unistd.h>
-+#include <sys/types.h>
-+#include <sys/socket.h>
-
- #include "sane/saneopts.h"
- #include "sane/sanei_config.h"
diff --git a/graphics/sane-backends/files/patch-backend_genesys_low.cpp b/graphics/sane-backends/files/patch-backend_genesys_low.cpp
deleted file mode 100644
index c1218914e832..000000000000
--- a/graphics/sane-backends/files/patch-backend_genesys_low.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
-Fix build on big endian archs:
-
-genesys/low.cpp:544:9: error: 'depth' was not declared in this scope, see
-
-https://gitlab.com/sane-project/backends/-/merge_requests/329
-
-Obtained from: OpenBSD
-
---- backend/genesys/low.cpp.orig 2020-02-02 11:58:09 UTC
-+++ backend/genesys/low.cpp
-@@ -539,7 +539,7 @@ Image read_unshuffled_image_from_scanner(Genesys_Devic
- }
-
- #ifdef WORDS_BIGENDIAN
-- if (depth == 16) {
-+ if (session.params.depth == 16) {
- dev->pipeline.push_node<ImagePipelineNodeSwap16BitEndian>();
- }
- #endif
diff --git a/graphics/sane-backends/files/patch-backend_pixma_pixma__bjnp.c b/graphics/sane-backends/files/patch-backend_pixma_pixma__bjnp.c
deleted file mode 100644
index cac58d20d3fa..000000000000
--- a/graphics/sane-backends/files/patch-backend_pixma_pixma__bjnp.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- backend/pixma/pixma_bjnp.c.orig 2020-02-03 09:33:57 UTC
-+++ backend/pixma/pixma_bjnp.c
-@@ -72,6 +72,7 @@
- #ifdef HAVE_UNISTD_H
- #include <unistd.h>
- #endif
-+#include <sys/param.h>
-
- /*
- * networking stuff
-@@ -1990,8 +1991,8 @@ sanei_bjnp_find_devices (const char **conf_devices,
- fd_set fdset;
- fd_set active_fdset;
- struct timeval timeout;
-- char scanner_host[HOST_NAME_MAX];
-- char uri[HOST_NAME_MAX + 32];
-+ char scanner_host[MAXHOSTNAMELEN];
-+ char uri[MAXHOSTNAMELEN + 32];
- int dev_no;
- int port;
- int auto_detect = 1;
diff --git a/graphics/sane-backends/files/patch-backend_ricoh2__buffer.c b/graphics/sane-backends/files/patch-backend_ricoh2__buffer.c
deleted file mode 100644
index f501a2d06195..000000000000
--- a/graphics/sane-backends/files/patch-backend_ricoh2__buffer.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- backend/ricoh2_buffer.c.orig 2020-02-02 11:58:09 UTC
-+++ backend/ricoh2_buffer.c
-@@ -50,7 +50,7 @@
- #if defined(__APPLE__) && defined(__MACH__)
- #include <malloc/malloc.h>
- #else
--#include <malloc.h>
-+#include <stdlib.h>
- #endif
-
- #include "../include/sane/sanei_debug.h"
diff --git a/graphics/sane-backends/files/patch-backend_umax__pp__low.c b/graphics/sane-backends/files/patch-backend_umax__pp__low.c
deleted file mode 100644
index bb9adc30cd4f..000000000000
--- a/graphics/sane-backends/files/patch-backend_umax__pp__low.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- backend/umax_pp_low.c.orig 2019-10-09 14:50:00 UTC
-+++ backend/umax_pp_low.c
-@@ -939,6 +939,10 @@ sanei_umax_pp_initPort (int port, char *name)
- int found = 0;
- int fd;
- # endif
-+# ifdef HAVE_DEV_PPBUS_PPI_H
-+ int found = 0;
-+ int fd;
-+# endif
- # ifdef HAVE_IOPERM
- int ectr;
- # endif
diff --git a/graphics/sane-backends/files/patch-backend_v4l.c b/graphics/sane-backends/files/patch-backend_v4l.c
deleted file mode 100644
index e50d809759ed..000000000000
--- a/graphics/sane-backends/files/patch-backend_v4l.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- backend/v4l.c.orig 2016-10-06 00:02:57 UTC
-+++ backend/v4l.c
-@@ -72,7 +72,10 @@
- #include "../include/sane/saneopts.h"
-
- #include <sys/ioctl.h>
-+
-+#ifdef HAVE_ASM_TYPES_H
- #include <asm/types.h> /* XXX glibc */
-+#endif
-
- #define BACKEND_NAME v4l
- #include "../include/sane/sanei_backend.h"
-@@ -1046,7 +1049,7 @@ sane_start (SANE_Handle handle)
- /* v4l1 actually returns BGR when we ask for RGB, so convert it */
- if (s->pict.palette == VIDEO_PALETTE_RGB24)
- {
-- __u32 loop;
-+ uint32_t loop;
- DBG (3, "sane_start: converting from BGR to RGB\n");
- for (loop = 0; loop < (s->window.width * s->window.height * 3); loop += 3)
- {
diff --git a/graphics/sane-backends/files/patch-configure b/graphics/sane-backends/files/patch-configure
index d9ed8b71fa0d..f7afda319020 100644
--- a/graphics/sane-backends/files/patch-configure
+++ b/graphics/sane-backends/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2020-02-02 11:58:46 UTC
+--- configure.orig 2020-08-23 11:59:54 UTC
+++ configure
-@@ -22138,7 +22138,7 @@ $as_echo_n "checking whether pthread_t is integer... "
+@@ -22134,7 +22134,7 @@ $as_echo_n "checking whether pthread_t is integer... "
int
main ()
{
@@ -9,7 +9,7 @@
;
return 0;
}
-@@ -26130,7 +26130,7 @@ for be in ${BACKENDS}; do
+@@ -26279,7 +26279,7 @@ for be in ${BACKENDS}; do
;;
v4l)
@@ -18,7 +18,7 @@
|| test "${have_libv4l1}" != "yes"; then
echo "*** $be backend requires v4l libraries - $DISABLE_MSG"
backend_supported="no"
-@@ -26339,7 +26339,7 @@ for be in ${BACKENDS}; do
+@@ -26482,7 +26482,7 @@ for be in ${BACKENDS}; do
;;
v4l)
diff --git a/graphics/sane-backends/files/patch-tools_sane-desc.c b/graphics/sane-backends/files/patch-tools_sane-desc.c
deleted file mode 100644
index 8c0288273a32..000000000000
--- a/graphics/sane-backends/files/patch-tools_sane-desc.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- tools/sane-desc.c.orig 2020-02-02 11:58:09 UTC
-+++ tools/sane-desc.c
-@@ -2816,8 +2816,8 @@ html_print_footer (void)
- "<address>\n"
- "<a href=\"imprint.html\"\n"
- ">Contact</a>\n" "</address>\n" "<font size=-1>\n");
-- printf ("This page was last updated on %s by sane-desc %s from %s\n",
-- asctime (localtime (&current_time)), SANE_DESC_VERSION, PACKAGE_STRING);
-+ printf ("This page was last updated by sane-desc %s from %s\n",
-+ SANE_DESC_VERSION, PACKAGE_STRING);
- printf ("</font>\n");
- printf ("</body> </html>\n");
- }
diff --git a/graphics/sane-backends/pkg-plist b/graphics/sane-backends/pkg-plist
index 155355309b7e..7dc805655eae 100644
--- a/graphics/sane-backends/pkg-plist
+++ b/graphics/sane-backends/pkg-plist
@@ -13,6 +13,7 @@ bin/umax_pp
@sample etc/sane.d/dist/canon.conf etc/sane.d/canon.conf
@sample etc/sane.d/dist/canon630u.conf etc/sane.d/canon630u.conf
@sample etc/sane.d/dist/canon_dr.conf etc/sane.d/canon_dr.conf
+@sample etc/sane.d/dist/canon_lide70.conf etc/sane.d/canon_lide70.conf
%%IEEE1284%%@sample etc/sane.d/dist/canon_pp.conf etc/sane.d/canon_pp.conf
@sample etc/sane.d/dist/cardscan.conf etc/sane.d/cardscan.conf
@sample etc/sane.d/dist/coolscan.conf etc/sane.d/coolscan.conf
@@ -121,6 +122,9 @@ lib/sane/libsane-canon630u.so.%%SOVERSION%%
lib/sane/libsane-canon_dr.so
lib/sane/libsane-canon_dr.so.1
lib/sane/libsane-canon_dr.so.%%SOVERSION%%
+lib/sane/libsane-canon_lide70.so
+lib/sane/libsane-canon_lide70.so.1
+lib/sane/libsane-canon_lide70.so.%%SOVERSION%%
%%IEEE1284%%lib/sane/libsane-canon_pp.so
%%IEEE1284%%lib/sane/libsane-canon_pp.so.1
%%IEEE1284%%lib/sane/libsane-canon_pp.so.%%SOVERSION%%
@@ -371,6 +375,7 @@ man/man5/sane-bh.5.gz
man/man5/sane-canon.5.gz
man/man5/sane-canon630u.5.gz
man/man5/sane-canon_dr.5.gz
+man/man5/sane-canon_lide70.5.gz
%%IEEE1284%%man/man5/sane-canon_pp.5.gz
man/man5/sane-cardscan.5.gz
man/man5/sane-coolscan.5.gz